aboutsummaryrefslogtreecommitdiffstats
path: root/community/allegro/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/allegro/APKBUILD')
-rw-r--r--community/allegro/APKBUILD32
1 files changed, 15 insertions, 17 deletions
diff --git a/community/allegro/APKBUILD b/community/allegro/APKBUILD
index 93cb1cc2c3e..75ce9c549a3 100644
--- a/community/allegro/APKBUILD
+++ b/community/allegro/APKBUILD
@@ -1,39 +1,38 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=allegro
-pkgver=5.2.7.0
-pkgrel=2
+pkgver=5.2.9.1
+pkgrel=0
arch="all"
url="https://liballeg.org"
pkgdesc="Portable library mainly aimed at video game and multimedia programming"
license="BSD-3-Clause"
makedepends="
+ alsa-lib-dev
cmake
- xorg-server-dev
- mesa-dev
+ flac-dev
glu-dev
- libxcursor-dev
+ gtk+3.0-dev
libjpeg-turbo-dev
- libwebp-dev
- flac-dev
+ libtheora-dev
libvorbis-dev
+ libwebp-dev
+ libxcursor-dev
libxi-dev
- libtheora-dev
- alsa-lib-dev
+ mesa-dev
pulseaudio-dev
+ samurai
+ xorg-server-dev
"
-source="https://github.com/liballeg/allegro5/archive/$pkgver/allegro5-$pkgver.tar.gz
- 0001-Use-the-compatibility-aliases-for-accessing-struct-i.patch
- "
+source="https://github.com/liballeg/allegro5/releases/download/$pkgver/allegro-$pkgver.tar.gz"
subpackages="$pkgname-dev"
-builddir="$srcdir/allegro5-$pkgver"
build() {
# sdl2 is disabled for now as it's experimental still
# and the tests are crashing on it
# https://github.com/liballeg/allegro5/issues/1229
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DALLEGRO_SDL=OFF \
-DWANT_TESTS=ON \
@@ -52,6 +51,5 @@ package() {
}
sha512sums="
-2b9b90e59f0f440ba90fe3fac0153245e96c46524c24fce74502569c2395a67aee73b83e4503ea21e7fe078113c4fb5752c984858e7f0647c9fa332415ddd3fe allegro5-5.2.7.0.tar.gz
-a376d987998cb30e5d1367da7d42277d8b9b774f091271f4c921b2d61716af5567c184cd36b23ca52d91724f13b3600612f507abc7cdfbfbfa70d559bb83f9d7 0001-Use-the-compatibility-aliases-for-accessing-struct-i.patch
+9b5fcaeda0ec229d4325a921d4765030de2c4169a750ec2084ad978d740b89a86d7db544088920f4438b0f9a9061068c1b8bc56b87898614d278282584853e10 allegro-5.2.9.1.tar.gz
"