aboutsummaryrefslogtreecommitdiffstats
path: root/community/alpine-repo-tools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/alpine-repo-tools/APKBUILD')
-rw-r--r--community/alpine-repo-tools/APKBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/community/alpine-repo-tools/APKBUILD b/community/alpine-repo-tools/APKBUILD
index 2d686726b1f..6013556b21d 100644
--- a/community/alpine-repo-tools/APKBUILD
+++ b/community/alpine-repo-tools/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=alpine-repo-tools
-pkgver=0.2
-pkgrel=3
+pkgver=0.3.0
+pkgrel=7
pkgdesc="utilities to interact with Alpine Linux repositories"
url="https://gitlab.alpinelinux.org/alpine/infra/repo-tools"
arch="all"
@@ -15,14 +15,18 @@ subpackages="
$pkgname-fish-completion
"
options="net !check" # no test suite
-source="https://gitlab.alpinelinux.org/alpine/infra/repo-tools/-/archive/v$pkgver/repo-tools-v$pkgver.tar.gz"
+source="https://gitlab.alpinelinux.org/alpine/infra/repo-tools/-/archive/v$pkgver/repo-tools-v$pkgver.tar.gz
+ fish.patch
+ "
builddir="$srcdir/repo-tools-v$pkgver"
provides="repo-tools=$pkgver-r$pkgrel"
replaces="repo-tools"
export GOFLAGS="$GOFLAGS -modcacherw"
-export GOMODCACHE="$srcdir/go"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
echo "$builddir"
@@ -36,5 +40,6 @@ package() {
}
sha512sums="
-c20bae9bf2be3cf954663319c4a561ba8c507ed2b8caebc12558dfe4503001b3ad8b24d7e3c159e82127d23e28328c0060c23c5bd5932a1362eca16eb273e07d repo-tools-v0.2.tar.gz
+d87d5be5654736e6b19bee807858c8d042ffd7904200a204bb83c008b15d7da8e4711a842f00a41420bcc909e059110fd6c28cca4c52e356284aaa019816023d repo-tools-v0.3.0.tar.gz
+642798931f85159a88cab72a4445b353e7388d62f2bec2552d7b4174a81d49967ef93c1e036c932daa20d6d6add8fe9aefbcbf2fbb2b6c3e9e7aff50885b56db fish.patch
"