aboutsummaryrefslogtreecommitdiffstats
path: root/community/alpine/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/alpine/APKBUILD')
-rw-r--r--community/alpine/APKBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/community/alpine/APKBUILD b/community/alpine/APKBUILD
index 9b5409ea2d8..7b36127abec 100644
--- a/community/alpine/APKBUILD
+++ b/community/alpine/APKBUILD
@@ -1,20 +1,19 @@
-# Maintainer: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
+# Maintainer: Kaarle Ritvanen <kunkku@alpinelinux.org>
pkgname=alpine
-pkgver=2.24
-pkgrel=1
-_commit=3165f59b344fb4d56d161541f294754d56bcb372
+pkgver=2.26
+pkgrel=2
pkgdesc="Text-based email client, friendly for novices but powerful"
-url="http://alpine.x10host.com/alpine/"
+url="https://repo.or.cz/alpine.git"
arch="all"
license="Apache-2.0"
-makedepends="openldap-dev heimdal-dev ncurses-dev openssl1.1-compat-dev"
+makedepends="openldap-dev heimdal-dev ncurses-dev openssl-dev>3"
subpackages="$pkgname-dbg $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://repo.or.cz/alpine.git/snapshot/$_commit.tar.gz
- 0001-ssl_unix-fix-server-name-validation.patch
- "
-builddir="$srcdir/$pkgname-${_commit:0:7}"
+source="$pkgname-$pkgver.tar.gz::https://repo.or.cz/alpine.git/snapshot/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-v$pkgver"
# secfixes:
+# 2.25-r0:
+# - CVE-2021-38370
# 2.23-r0:
# - CVE-2020-14929
@@ -28,12 +27,13 @@ build() {
--disable-shared \
--with-system-pinerc=/etc/alpine.d/pine.conf \
--with-system-fixed-pinerc=/etc/alpine.d/pine.conf.fixed
- make
+ make -j1
}
package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="648618fd965fd600ee5d870cfcb87aeb5792311236c5b476f337d2202c460db5c37c5d170430c177cd4ab7c806eff10ee1c327c5ada9253f7d07b6a54442a6d3 alpine-2.24.tar.gz
-5e10289f292139bf576e40bda0f3539d62024309650473a2fdbb281e5d7691cc4c1d3d21f78615e2c900766eddba076f512d92f60d4fbb61e1683f35cba185aa 0001-ssl_unix-fix-server-name-validation.patch"
+sha512sums="
+7ca4d5fc7cc9b5fc63b0cb341fa161274c7f724d3f812a7f94dcfe60d678665f0fbce5b671fa26d4da822f09ac58978a3f6385a94c8f3dc9b16bd8fa66a49634 alpine-2.26.tar.gz
+"