aboutsummaryrefslogtreecommitdiffstats
path: root/community/althttpd/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/althttpd/APKBUILD')
-rw-r--r--community/althttpd/APKBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/community/althttpd/APKBUILD b/community/althttpd/APKBUILD
index 9e1f7a3a0ac..8f64b2b31e8 100644
--- a/community/althttpd/APKBUILD
+++ b/community/althttpd/APKBUILD
@@ -1,22 +1,27 @@
# Contributor: Sodface <sod@sodface.com>
# Maintainer: Sodface <sod@sodface.com>
pkgname=althttpd
-pkgver=202108141729
+pkgver=202402211453
pkgrel=0
pkgdesc="Small, simple, stand-alone HTTP server"
url="https://sqlite.org/althttpd/doc/trunk/althttpd.md"
arch="all"
license="Public-Domain"
+makedepends="openssl-dev>3"
options="!check" # no test suite
-subpackages="$pkgname-openrc"
-source="$pkgname-$pkgver.zip::https://sqlite.org/althttpd/zip?in=althttpd.c&r=$pkgver
+subpackages="$pkgname-doc $pkgname-openrc"
+source="
+ $pkgname-$pkgver.tar.gz::https://sqlite.org/althttpd/tarball?r=$pkgver
10-allow-filename-plus-sign.patch
$pkgname.confd
- $pkgname.initd"
-builddir="$srcdir/"
+ $pkgname.initd
+ "
+builddir="$srcdir"
build() {
- gcc $CFLAGS althttpd.c $LDFLAGS -o althttpd
+ sed -in -e 's/^CFLAGS=/CFLAGS+=/' \
+ -e 's|/bin/bash|/bin/sh|' Makefile
+ make althttpsd
}
package() {
@@ -24,12 +29,15 @@ package() {
"$pkgdir"/etc/conf.d/althttpd
install -Dm 755 "$srcdir"/althttpd.initd \
"$pkgdir"/etc/init.d/althttpd
- install -D althttpd "$pkgdir"/usr/bin/althttpd
+ install -D althttpsd \
+ "$pkgdir"/usr/bin/althttpd
+ install -Dm644 althttpd.md \
+ "$pkgdir"/usr/share/doc/$pkgname/althttpd.md
}
sha512sums="
-4b3fe1d2bd6eab1048f6329741322b9dee73493f070bcb84294b6e8150d093b934b01cae74778e22536330dd97f27a119181edfd32401333a020eb3df6e2935b althttpd-202108141729.zip
-d31628a3b6617cc49156fe3680c3d4f964a0b2ed7570edc23b9d52ed6fe7693022067a051b60d2fcb5f695be5a3daa8589fa9ba3c1ac12bd03306925e8a10015 10-allow-filename-plus-sign.patch
-aeb1252915176d11cddb1ff5f1c13f532bb3df8f52760f71ae087fde90a4d4422cc65570a59adac12232dacc5aed67a673790a019a3d53203899b7909ca8503b althttpd.confd
+8a5c1df74c4c9566593fdf505c9bad1af1a7edf185bf0854105eb5cadddbfca2e650f854c87461d8d514adb1015d03a1b14f5e543e505b43997980899d5a8d89 althttpd-202402211453.tar.gz
+ece2633a822589f1e49129bf00fb4b066e9d079e3e56f7c78e3bcba02c8aad9ae3ee75f6459360524d7c2a3a7dc7cfea4eb1652b4cbf1aff60d968e1f816b535 10-allow-filename-plus-sign.patch
+41f0015f98f108067b42a4a2487c7c89653388a1c3c4a94884fedf5f704f05cdcc189ea81e7a01a8ec8408045b72ee06b6f1063e5b7cd5e67318d42b4c0add89 althttpd.confd
f21867430470b836d97d60215d9dda835125140cced3bb9c856349228572f2c73ac0574d3f705d72938879fc2b5a37855768a5f7de5c29943e3aa6ead5d72d9c althttpd.initd
"