aboutsummaryrefslogtreecommitdiffstats
path: root/community/animatch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/animatch/APKBUILD')
-rw-r--r--community/animatch/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/community/animatch/APKBUILD b/community/animatch/APKBUILD
index c98829d08be..42f3cfff408 100644
--- a/community/animatch/APKBUILD
+++ b/community/animatch/APKBUILD
@@ -2,17 +2,18 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=animatch
pkgver=1.0.3
-pkgrel=1
+pkgrel=5
_commit_libsuperderpy="d26adecc8eac53b5c9fa999fbd86c880418c01ed"
arch="all"
url="https://gitlab.com/HolyPangolin/animatch"
pkgdesc="Animatch is a match-three game with cute animals"
license="GPL-3.0-or-later"
makedepends="
- cmake
- ninja
allegro-dev
- mesa-dev"
+ cmake
+ mesa-dev
+ samurai
+ "
source="https://gitlab.com/HolyPangolin/animatch/-/archive/v$pkgver/animatch-v$pkgver.tar.gz
libsuperderpy-$_commit_libsuperderpy.tar.gz::https://gitlab.com/dosowisko.net/libsuperderpy/-/archive/$_commit_libsuperderpy.tar.gz
"
@@ -29,7 +30,7 @@ prepare() {
}
build() {
- cmake -B build \
+ cmake -B build -G Ninja \
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_SHARED_LIBS=OFF \