aboutsummaryrefslogtreecommitdiffstats
path: root/community/ansible-base/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ansible-base/APKBUILD')
-rw-r--r--community/ansible-base/APKBUILD69
1 files changed, 69 insertions, 0 deletions
diff --git a/community/ansible-base/APKBUILD b/community/ansible-base/APKBUILD
new file mode 100644
index 00000000000..a856540dcbc
--- /dev/null
+++ b/community/ansible-base/APKBUILD
@@ -0,0 +1,69 @@
+# Contributor: Łukasz Jendrysik <scadu@yandex.com>
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Takuya Noguchi <takninnovationresearch@gmail.com>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=ansible-base
+pkgver=2.10.5
+pkgrel=1
+pkgdesc="A configuration-management, deployment, task-execution, and multinode orchestration framework"
+url="https://ansible.com/"
+options="!check" # TODO: enable tests
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="python3 py3-jinja2 py3-packaging py3-yaml py3-cryptography py3-paramiko"
+makedepends="py3-setuptools"
+subpackages="$pkgname-doc"
+source="https://pypi.python.org/packages/source/a/ansible-base/ansible-base-$pkgver.tar.gz
+ 0001-new-module-lbu.patch
+ "
+
+# secfixes:
+# 2.9.13-r0:
+# - CVE-2020-14330
+# - CVE-2020-14332
+# - CVE-2020-14365
+# 2.9.7-r0:
+# - CVE-2019-3828
+# - CVE-2020-1733
+# - CVE-2020-1739
+# - CVE-2020-1740
+# - CVE-2020-1746
+# - CVE-2020-10691
+# 2.9.6-r0:
+# - CVE-2020-1737
+# 2.9.3-r0:
+# - CVE-2019-14904
+# - CVE-2019-14905
+# 2.8.6-r0:
+# - CVE-2019-14846
+# - CVE-2019-14856
+# - CVE-2019-14858
+# 2.8.4-r0:
+# - CVE-2019-10206
+# - CVE-2019-10217
+# 2.8.2-r0:
+# - CVE-2019-10156
+# 2.7.9-r0:
+# - CVE-2018-16876
+# 2.6.3-r0:
+# - CVE-2018-10875
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ mkdir -p "$pkgdir"/usr/share/man/man1
+ install -Dm644 "$builddir"/docs/man/man1/*.1 \
+ "$pkgdir"/usr/share/man/man1/
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname/examples/
+ cp -r examples/* \
+ "$pkgdir"/usr/share/doc/$pkgname/examples/
+ install -m644 README.rst "$pkgdir"/usr/share/doc/$pkgname
+}
+
+sha512sums="2449a36bdea7242a3f4e248e42388339299340cd6c377d6a20b02803db527895912e49040f3931a1aa2ebf04e3d4d5594cfc08aec28da44b73c8206dc81ddb89 ansible-base-2.10.5.tar.gz
+57364eb94bd5fa1add6fb2f60d4e3790a6f1d7582f92ec1e25ea9459704d12ffe49b09ebde4aef91463d1950cfc9a4a34ab2ef83c60f1bc1c1fb6399e900369d 0001-new-module-lbu.patch"