aboutsummaryrefslogtreecommitdiffstats
path: root/community/ansible-lint/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ansible-lint/APKBUILD')
-rw-r--r--community/ansible-lint/APKBUILD72
1 files changed, 47 insertions, 25 deletions
diff --git a/community/ansible-lint/APKBUILD b/community/ansible-lint/APKBUILD
index e3f649fab15..587bd27308f 100644
--- a/community/ansible-lint/APKBUILD
+++ b/community/ansible-lint/APKBUILD
@@ -1,47 +1,69 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=ansible-lint
-pkgver=4.3.7
-pkgrel=4
+pkgver=24.2.1
+pkgrel=0
pkgdesc="check ansible playbooks"
url="https://github.com/ansible/ansible-lint"
-# Disable for now, fails with new setuptools
-#arch="noarch"
-options="!check" # see https://gitlab.alpinelinux.org/alpine/aports/-/issues/12225
+arch="noarch"
+options="!check"
license="MIT"
depends="
- ansible
+ ansible-core
+ black
+ git
+ py3-ansible-compat
+ py3-filelock
+ py3-jinja2
+ py3-jsonschema
+ py3-packaging
+ py3-requests
py3-rich
- py3-yaml
- py3-six
py3-ruamel.yaml
- py3-typing-extensions
+ py3-wcmatch
+ py3-yaml
+ python3
+ yamllint
+ "
+makedepends="
+ py3-gpep517
+ py3-installer
+ py3-setuptools
+ py3-setuptools_scm
+ py3-wheel
+ "
+checkdepends="
+ py3-flaky
+ py3-psutil
+ py3-pytest
+ py3-pytest-cov
+ py3-pytest-xdist
+ yamllint
+ "
+subpackages="$pkgname-pyc"
+source="ansible-lint-$pkgver.tar.gz::https://github.com/ansible-community/ansible-lint/archive/refs/tags/v$pkgver/ansible-lint-v$pkgver.tar.gz
+ no-version-check.patch
"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest py3-pytest-cov"
-source="https://files.pythonhosted.org/packages/source/a/ansible-lint/ansible-lint-$pkgver.tar.gz"
provides="py3-ansible-lint=$pkgver-r$pkgrel" # for backward compatibility
replaces="py3-ansible-lint" # for backward compatibility
-prepare() {
- default_prepare
- # stop setuptools from using the scm version which doesn't exist in this context
- sed -e "/^\[metadata\]/a version = $pkgver" \
- -e '/^use_scm_version/d' \
- -e '/setuptools_scm/d' \
- -i setup.cfg
-}
-
build() {
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ pytest
}
package() {
- python3 setup.py install --skip-build --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/ansible_lint-$pkgver-py3-none-any.whl
}
-sha512sums="b882c8b8edc37e530052f7d6bf97e6c48f4a13fa6c6f6373c9fcafb7ffe2fc7dcfc5938ae6c61fd832a9ea989bd0a23f68f93f6339c9e52e9100875f5ebd69af ansible-lint-4.3.7.tar.gz"
+sha512sums="
+8b997543f8e1ee250ab3c0d73eb1b9445ee53ffde0976e45c52e8b557d57f50d9846d7ba56ad07d1a8e59dba4b3b078583862245154dac5a524c2d126ff29c4a ansible-lint-24.2.1.tar.gz
+314fa02e0b30db8a8886824b0cce825ae4ffe227e2c5be434bc96e1c3ab8a6239548574d9ed0869def67b94c684a67abbf594f78aadbc64286fe8187502ba275 no-version-check.patch
+"