aboutsummaryrefslogtreecommitdiffstats
path: root/community/ansible/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ansible/APKBUILD')
-rw-r--r--community/ansible/APKBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/community/ansible/APKBUILD b/community/ansible/APKBUILD
index 8112401ab8b..61e34042659 100644
--- a/community/ansible/APKBUILD
+++ b/community/ansible/APKBUILD
@@ -1,17 +1,23 @@
# Contributor: Łukasz Jendrysik <scadu@yandex.com>
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Takuya Noguchi <takninnovationresearch@gmail.com>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Sean McAvoy <seanmcavoy@gmail.com>
pkgname=ansible
-pkgver=4.9.0
-pkgrel=0
+pkgver=9.4.0
+pkgrel=2
pkgdesc="core components for Ansible"
url="https://ansible.com/"
options="!check" # TODO: enable tests
arch="noarch"
license="GPL-3.0-or-later"
-depends="python3 ansible-core"
-makedepends="py3-setuptools"
+depends="python3 ansible-core>=2.16.0"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/a/ansible/ansible-$pkgver.tar.gz"
# secfixes:
@@ -21,13 +27,16 @@ source="https://pypi.python.org/packages/source/a/ansible/ansible-$pkgver.tar.gz
# - CVE-2020-25646
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-75b3214cd8321cfc349613254b4df7fc35182fa5d35a0d771a8dfbca17ce14ef1f2acdaca325e6cd913abd94ffc7142c2d00925d217da21268810c3e812f8dbb ansible-4.9.0.tar.gz
+4c75235a866f3f95cda8dd3b6c9d22b916ad117d54a86a30585f71c9015cd98db764afa225af5b2f6fa884af558ee488785e26c9e8b9e8be105062f069f065b2 ansible-9.4.0.tar.gz
"