aboutsummaryrefslogtreecommitdiffstats
path: root/community/apenwarr-redo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/apenwarr-redo/APKBUILD')
-rw-r--r--community/apenwarr-redo/APKBUILD36
1 files changed, 24 insertions, 12 deletions
diff --git a/community/apenwarr-redo/APKBUILD b/community/apenwarr-redo/APKBUILD
index 5c965eaddaf..958c8673e66 100644
--- a/community/apenwarr-redo/APKBUILD
+++ b/community/apenwarr-redo/APKBUILD
@@ -1,16 +1,16 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=apenwarr-redo
-pkgver=0.42c
-pkgrel=1
+pkgver=0.42d
+pkgrel=2
pkgdesc="Smaller, easier, more powerful, and more reliable than make"
url="https://redo.readthedocs.io/en/latest/"
arch="noarch"
license="Apache-2.0"
depends="python3"
-makedepends="perl"
+makedepends="perl py3-beautifulsoup4 py3-markdown"
checkdepends="cpio"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-bash-completion $pkgname-doc $pkgname-pyc"
source="https://github.com/apenwarr/redo/archive/redo-$pkgver.tar.gz
fix-env-python.patch
"
@@ -18,28 +18,40 @@ provides="redo"
provider_priority=50
builddir="$srcdir/redo-redo-$pkgver"
+options="chmod-clean"
build() {
./do build
+ find docs -name 'redo*.md' | sed 's/md$/1/' | xargs bin/redo
}
check() {
# Causes issues with the test suite
- unset CC CPPFLAGS CFLAGS CXX CXXFLAGS LDFLAGS
+ unset ARCH CC CPPFLAGS CFLAGS CXX CXXFLAGS LDFLAGS
+
+ # Not compattible with make 4.4 yet (jobserver-fifo)
+ rm -r t/203-make
+
./do test
}
package() {
DESTDIR="$pkgdir" PREFIX="/usr" ./do install
+ install -Dm644 contrib/bash_completion.d/redo \
+ "$pkgdir"/usr/share/bash-completion/completions/redo.sh
+ install -Dm644 docs/*.1 \
+ "$pkgdir"/usr/share/man/man1/
}
-cleanup_srcdir() {
- # Test suite changes some files to read-only, resulting in errors on
- # cleanup.
- [ -e "$srcdir" ] && chmod -R a+w "$srcdir"
+pyc() {
+ default_pyc
- default_cleanup_srcdir
+ amove \
+ usr/lib/redo/__pycache__ \
+ usr/lib/redo/version/__pycache__
}
-sha512sums="764ef84cfb56d5dd883cf80f706a567491e1a679d136219c4db3c122386aad3cfbd28131dc231a91639f596d7b8819c4254e4e7fa38f917996ca8bf3e1a5dc19 redo-0.42c.tar.gz
-8b01a70e0812bf6c90c8447d110eac91639c35e3e3c20a083d4ed68fe0b3a3524081ad94fa1fd504525b7ebf5ef1fd5aff9fe3b933fe9f0aa2a404426ed96471 fix-env-python.patch"
+sha512sums="
+2749a1a1046f8edd63c4b4e2b0f4d95988dfcf8c776b264007914e583fc21ff51447be34ffc2c136c343ace8c38147d6a43c0c0dd01a681b6283a38d5d8f3fb7 redo-0.42d.tar.gz
+7d8be0b94999c54d6d1d47300189c4979294cf3d9ddd30f2f3c95b12f16e7dc180ad7c518bcf1dd91f3ddace8e769880ac30bf659f4c9973872cb75bc15d89c7 fix-env-python.patch
+"