aboutsummaryrefslogtreecommitdiffstats
path: root/community/apitrace/no-submodule.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/apitrace/no-submodule.patch')
-rw-r--r--community/apitrace/no-submodule.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/apitrace/no-submodule.patch b/community/apitrace/no-submodule.patch
new file mode 100644
index 00000000000..ab4e2b9e1e6
--- /dev/null
+++ b/community/apitrace/no-submodule.patch
@@ -0,0 +1,29 @@
+diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
+index 7eae7e55..85d1168d 100644
+--- a/thirdparty/CMakeLists.txt
++++ b/thirdparty/CMakeLists.txt
+@@ -13,24 +13,6 @@ function (include_with_scope)
+ include (${ARGV})
+ endfunction ()
+
+-set (SUBMODULES_MISSING FALSE)
+-foreach (path IN ITEMS
+- brotli/LICENSE
+- gtest/googletest/LICENSE
+- libbacktrace/LICENSE
+- libpng/LICENSE
+- snappy/COPYING
+- zlib/README
+-)
+- if (NOT EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/${path}")
+- message (SEND_ERROR "error: ${CMAKE_CURRENT_SOURCE_DIR}/${path} does not exist")
+- set (SUBMODULES_MISSING TRUE)
+- endif ()
+-endforeach ()
+-if (SUBMODULES_MISSING)
+- message (FATAL_ERROR "Update Git submodules by running\ngit submodule update --init --depth 1 --recursive")
+-endif ()
+-
+ if (ENABLE_STATIC_SNAPPY OR NOT Snappy_FOUND)
+ message (STATUS "Using bundled Snappy")
+ include_with_scope (snappy.cmake)