aboutsummaryrefslogtreecommitdiffstats
path: root/community/appstream-glib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/appstream-glib/APKBUILD')
-rw-r--r--community/appstream-glib/APKBUILD36
1 files changed, 20 insertions, 16 deletions
diff --git a/community/appstream-glib/APKBUILD b/community/appstream-glib/APKBUILD
index 24be3fa8270..3ef10e6cb6d 100644
--- a/community/appstream-glib/APKBUILD
+++ b/community/appstream-glib/APKBUILD
@@ -1,27 +1,27 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=appstream-glib
-pkgver=0.7.18
-pkgrel=2
+pkgver=0.8.2
+pkgrel=1
pkgdesc="Library for AppStream metadata"
url="https://people.freedesktop.org/~hughsient/appstream-glib/"
arch="all"
license="LGPL-2.0-or-later"
depends="gsettings-desktop-schemas"
makedepends="
- meson
- glib-dev
- libarchive-dev
- libsoup-dev
- json-glib-dev
- gdk-pixbuf-dev
- gtk+3.0-dev
- freetype-dev
+ curl-dev
fontconfig-dev
- yaml-dev
+ freetype-dev
+ gdk-pixbuf-dev
+ glib-dev
+ gobject-introspection-dev
gperf
+ gtk+3.0-dev
+ json-glib-dev
+ libarchive-dev
libgcab-dev
- gobject-introspection-dev
+ meson
+ yaml-dev
"
subpackages="
$pkgname-dbg
@@ -31,10 +31,13 @@ subpackages="
$pkgname-builder
$pkgname-bash-completion:bashcomp:noarch
"
-source="https://people.freedesktop.org/~hughsient/appstream-glib/releases/appstream-glib-$pkgver.tar.xz"
+source="https://people.freedesktop.org/~hughsient/appstream-glib/releases/appstream-glib-$pkgver.tar.xz
+ as-yaml-support-application-yaml-mimetype.patch
+ "
build() {
abuild-meson \
+ -Db_lto=true \
-Ddep11=true \
-Dbuilder=true \
-Drpm=false \
@@ -45,11 +48,11 @@ build() {
-Dgtk-doc=false \
-Dintrospection=true \
output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -79,5 +82,6 @@ bashcomp() {
}
sha512sums="
-2a202eb25d823d524128a8ab164025b6579e069f8b62373cf5447d049a0e3764fca5bf1464296101a45870d1426b094493fc8ead07a6a4bcb514c0f1a91e8ff2 appstream-glib-0.7.18.tar.xz
+c9c21049ab43f5da8595aa07a3c2e097163a05b5e0fc030e4e3326136cd18127f04ad9edf08c12aea823b89048b43808cc60759cc26fcf2541cd9c1acbb29e28 appstream-glib-0.8.2.tar.xz
+c6b585a1e42bbc9d71b355e14712d79092a5f07c2afe762764a9e71e72044ef51eecbcb07447291b454cb35ce84225dd7ffd14ce3d83753d482309b78ef26a93 as-yaml-support-application-yaml-mimetype.patch
"