aboutsummaryrefslogtreecommitdiffstats
path: root/community/appstream-glib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/appstream-glib/APKBUILD')
-rw-r--r--community/appstream-glib/APKBUILD57
1 files changed, 29 insertions, 28 deletions
diff --git a/community/appstream-glib/APKBUILD b/community/appstream-glib/APKBUILD
index f4616000616..3ef10e6cb6d 100644
--- a/community/appstream-glib/APKBUILD
+++ b/community/appstream-glib/APKBUILD
@@ -1,39 +1,43 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=appstream-glib
-pkgver=0.7.16
-pkgrel=0
+pkgver=0.8.2
+pkgrel=1
pkgdesc="Library for AppStream metadata"
url="https://people.freedesktop.org/~hughsient/appstream-glib/"
arch="all"
license="LGPL-2.0-or-later"
depends="gsettings-desktop-schemas"
makedepends="
- meson
- glib-dev
- libarchive-dev
- libsoup-dev
- json-glib-dev
- gdk-pixbuf-dev
- gtk+3.0-dev
- freetype-dev
+ curl-dev
fontconfig-dev
- yaml-dev
+ freetype-dev
+ gdk-pixbuf-dev
+ glib-dev
+ gobject-introspection-dev
gperf
+ gtk+3.0-dev
+ json-glib-dev
+ libarchive-dev
libgcab-dev
- gobject-introspection-dev
+ meson
+ yaml-dev
"
subpackages="
+ $pkgname-dbg
$pkgname-dev
$pkgname-doc
$pkgname-lang
$pkgname-builder
- $pkgname-bash-completion:bashcomp:noarch"
-source="https://people.freedesktop.org/~hughsient/appstream-glib/releases/appstream-glib-$pkgver.tar.xz"
+ $pkgname-bash-completion:bashcomp:noarch
+ "
+source="https://people.freedesktop.org/~hughsient/appstream-glib/releases/appstream-glib-$pkgver.tar.xz
+ as-yaml-support-application-yaml-mimetype.patch
+ "
build() {
- meson \
- --prefix=/usr \
+ abuild-meson \
+ -Db_lto=true \
-Ddep11=true \
-Dbuilder=true \
-Drpm=false \
@@ -44,21 +48,15 @@ build() {
-Dgtk-doc=false \
-Dintrospection=true \
output
- ninja -C output
+ meson compile -C output
}
check() {
- case "$CARCH" in
- armv7|armhf)
- # Flaky tests, fail or pass on drone ci alternating between pushes
- return 0
- ;;
- esac
- ninja -C output test
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- DESTDIR="$pkgdir" ninja -C output install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
# Remove installed tests
rm -rf "$pkgdir"/usr/share/installed-tests/appstream-glib
@@ -80,7 +78,10 @@ bashcomp() {
pkgdesc="Bash completions for $pkgname"
install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
- install -Dm644 "$pkgdir"/usr/share/bash-completion/completions/* \
- "$subpkgdir"/usr/share/bash-completion/completions
+ amove usr/share/bash-completion/completions
}
-sha512sums="a2991dbd26deeb1fb1daef1811c38ff5b55b2fae0bf2d8cc612c2e370613cb6b0468cf287ab3b575f6e6e3203aabcca12dd95474f70a54d6052a34dcb27b951b appstream-glib-0.7.16.tar.xz"
+
+sha512sums="
+c9c21049ab43f5da8595aa07a3c2e097163a05b5e0fc030e4e3326136cd18127f04ad9edf08c12aea823b89048b43808cc60759cc26fcf2541cd9c1acbb29e28 appstream-glib-0.8.2.tar.xz
+c6b585a1e42bbc9d71b355e14712d79092a5f07c2afe762764a9e71e72044ef51eecbcb07447291b454cb35ce84225dd7ffd14ce3d83753d482309b78ef26a93 as-yaml-support-application-yaml-mimetype.patch
+"