aboutsummaryrefslogtreecommitdiffstats
path: root/community/appstream-glib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/appstream-glib/APKBUILD')
-rw-r--r--community/appstream-glib/APKBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/community/appstream-glib/APKBUILD b/community/appstream-glib/APKBUILD
index 36d6db27135..3ef10e6cb6d 100644
--- a/community/appstream-glib/APKBUILD
+++ b/community/appstream-glib/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=appstream-glib
-pkgver=0.8.0
+pkgver=0.8.2
pkgrel=1
pkgdesc="Library for AppStream metadata"
url="https://people.freedesktop.org/~hughsient/appstream-glib/"
@@ -32,12 +32,12 @@ subpackages="
$pkgname-bash-completion:bashcomp:noarch
"
source="https://people.freedesktop.org/~hughsient/appstream-glib/releases/appstream-glib-$pkgver.tar.xz
- fix-self-test.patch
- $pkgname-fix-proxy.patch::https://github.com/hughsie/appstream-glib/commit/323f4ea96f95d1522b951963a5d91e5320d38274.patch
+ as-yaml-support-application-yaml-mimetype.patch
"
build() {
abuild-meson \
+ -Db_lto=true \
-Ddep11=true \
-Dbuilder=true \
-Drpm=false \
@@ -48,11 +48,11 @@ build() {
-Dgtk-doc=false \
-Dintrospection=true \
output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -82,7 +82,6 @@ bashcomp() {
}
sha512sums="
-13aeb37b8e890691a14d20ed0a86a14ae7125a6e08e60adcefe58ce2f861cebf7f49a01d9d1c137205b923f3162b307fc2671d476b7aaa9eae5fc5234ea4c1da appstream-glib-0.8.0.tar.xz
-d3381faa19a7d4bb4bccdbd036b5c013f3941b1dec496e3d4108a61c27a138c227b880287130134021aaf1d200a6351463f39619aae2f805e923787ca540e1a3 fix-self-test.patch
-308f4ccb3daeb1da4cdb4fdb5c6d42c2864b1e4ea9d14132abcb2a9504b1971b10a365d3490b293032caeb4ac0631ad687d26150b19a43706b4f55bf092004db appstream-glib-fix-proxy.patch
+c9c21049ab43f5da8595aa07a3c2e097163a05b5e0fc030e4e3326136cd18127f04ad9edf08c12aea823b89048b43808cc60759cc26fcf2541cd9c1acbb29e28 appstream-glib-0.8.2.tar.xz
+c6b585a1e42bbc9d71b355e14712d79092a5f07c2afe762764a9e71e72044ef51eecbcb07447291b454cb35ce84225dd7ffd14ce3d83753d482309b78ef26a93 as-yaml-support-application-yaml-mimetype.patch
"