aboutsummaryrefslogtreecommitdiffstats
path: root/community/appstream/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/appstream/APKBUILD')
-rw-r--r--community/appstream/APKBUILD80
1 files changed, 48 insertions, 32 deletions
diff --git a/community/appstream/APKBUILD b/community/appstream/APKBUILD
index 90aa68c3b2c..30b110e0d32 100644
--- a/community/appstream/APKBUILD
+++ b/community/appstream/APKBUILD
@@ -1,35 +1,49 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Pablo Correa Gomez <ablocorrea@hotmail.com>
pkgname=appstream
-pkgver=0.14.3
-pkgrel=0
+pkgver=1.0.2
+pkgrel=2
pkgdesc="Provides a standard for creating app stores across distributions"
url="https://distributions.freedesktop.org/wiki/AppStream"
arch="all"
-license="LGPL-2.1-or-later AND GPL-2.0-or-later"
-makedepends="meson yaml-dev libxml2-dev glib-dev lmdb-dev gobject-introspection-dev
- gperf qt5-qtbase-dev libsoup-dev curl-dev"
-triggers="$pkgname.trigger=/usr/share/app-info/*"
+license="LGPL-2.1-or-later"
+makedepends="
+ cairo-dev
+ curl-dev
+ fontconfig-dev
+ gdk-pixbuf-dev
+ glib-dev
+ gobject-introspection-dev
+ gperf
+ itstool
+ librsvg-dev
+ libxml2-dev
+ libxmlb-dev
+ meson
+ pango-dev
+ qt6-qtbase-dev
+ yaml-dev
+ "
+triggers="$pkgname.trigger=/usr/share/app-info/*:/var/cache/swcatalog/xml"
install="$pkgname.post-install $pkgname.post-upgrade"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-qt $pkgname-lang $pkgname-dbg"
+subpackages="
+ $pkgname-dbg
+ $pkgname-dev
+ $pkgname-doc
+ $pkgname-qt
+ $pkgname-compose
+ $pkgname-lang
+ "
source="https://www.freedesktop.org/software/appstream/releases/AppStream-$pkgver.tar.xz
- tests-meson-fix-nested-list.patch
"
builddir="$srcdir/AppStream-$pkgver"
-# librsvg doesn't exist on these arches
-case "$CARCH" in
- s390x|mips*) ;;
- *)
- makedepends="$makedepends gdk-pixbuf-dev librsvg-dev pango-dev"
- subpackages="$subpackages $pkgname-compose"
- _conf="-Dcompose=true"
- ;;
-esac
-
build() {
abuild-meson \
+ -Db_lto=true \
-Dqt=true \
+ -Dsystemd=false \
-Ddocs=false \
-Dapidocs=false \
-Dinstall-docs=false \
@@ -37,38 +51,40 @@ build() {
-Dvapi=false \
-Dapt-support=false \
-Dgir=true \
- $_conf \
+ -Dcompose=true \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ XDG_RUNTIME_DIR="$builddir" \
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
+
+ # Remove installed-tests, there is no switch to disable installing them
+ rm -rf "$pkgdir"/usr/share/installed-tests
}
compose() {
pkgdesc="Building blocks to compose AppStream metadata"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libappstream-compose* \
- "$pkgdir"/usr/lib/girepository-1.0/AppStreamCompose* \
- "$subpkgdir"/usr/lib
+ amove usr/lib/libappstream-compose*
+ amove usr/lib/girepository-*/AppStreamCompose*
+
+ # Needs so:libappstream-compose.so and thus needs
+ # to be moved to prevent a recursive dependency.
+ amove usr/libexec/appstreamcli-compose
}
qt() {
pkgdesc="Qt5 interface for AppStream"
- license="LGPL-2.1-or-later"
- mkdir -p "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libAppStreamQt.so.* "$subpkgdir"/usr/lib
+ amove usr/lib/libAppStreamQt.so.*
}
-
sha512sums="
-b4c41b44375091636cc46e2f7f5e0b86612474faa6d55010caee78cb9c9ac468d093cf261184d900be7aae8513dc72d2821ff9ee17786e123c86a928ce5e9135 AppStream-0.14.3.tar.xz
-f545d979f1a74cc4728b39bce8d5c04fed83f392c207cfa4620875fabc11ebee4c8bc6ee594428629bf673a9b051e596ff72f700aba6af566e43e9ce6b788372 tests-meson-fix-nested-list.patch
+e5c109c383e3bf3af3693bfb3146663767c2c61fac0bd421f2ce52242fe7b869effeacc4d207987321dfeb4ab0ba77ece6c1c6eea054a7365204cd955426517a AppStream-1.0.2.tar.xz
"