aboutsummaryrefslogtreecommitdiffstats
path: root/community/ark/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ark/APKBUILD')
-rw-r--r--community/ark/APKBUILD33
1 files changed, 17 insertions, 16 deletions
diff --git a/community/ark/APKBUILD b/community/ark/APKBUILD
index af588332ff4..342459536c4 100644
--- a/community/ark/APKBUILD
+++ b/community/ark/APKBUILD
@@ -1,18 +1,19 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=ark
-pkgver=21.04.1
+pkgver=24.02.2
pkgrel=0
pkgdesc="Graphical file compression/decompression utility with support for multiple formats"
# armhf blocked by extra-cmake-modules
-# s390x blocked by kiconthemes
-arch="all !armhf !s390x !mips64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.ark"
license="GPL-2.0-only"
depends="
+ 7zip-virtual
lrzip
- p7zip
- unrar
unzip
zip
zstd
@@ -24,6 +25,7 @@ makedepends="
kcrash-dev
kdbusaddons-dev
kdoctools-dev
+ kfilemetadata-dev
ki18n-dev
kiconthemes-dev
kio-dev
@@ -34,13 +36,15 @@ makedepends="
kwidgetsaddons-dev
libarchive-dev
libzip-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
shared-mime-info
xz-dev
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/ark-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/ark.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/ark-$pkgver.tar.xz"
# secfixes:
# 20.08.0-r1:
@@ -48,24 +52,21 @@ subpackages="$pkgname-doc $pkgname-lang"
# 20.04.3-r1:
# - CVE-2020-16116
-
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- # plugins-cliunarchivertest is broken since Qt 5.11
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "plugins-clirartest"
+ xvfb-run ctest --test-dir build --output-on-failure -E "(app-batchextract|kerfuffle-(preservemetadata|adddialog))test"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-fe6e64c2e18809cd7731f2add8d51563326718d685d4981dc3f3af0d58fcdb07548b414fa738f39fb6dc50cc6038d9b20750c54bfd8f95610c000de431f02ae7 ark-21.04.1.tar.xz
+419769f9bd3644670c7cb4d53bc9c683c92fb92e2dae117953791e0074093814d455676aa25237fa2209453c730156c40b7082ad3683e69c7dd619d222c9469b ark-24.02.2.tar.xz
"