aboutsummaryrefslogtreecommitdiffstats
path: root/community/ark/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ark/APKBUILD')
-rw-r--r--community/ark/APKBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/community/ark/APKBUILD b/community/ark/APKBUILD
index 10706be2668..435f003e19f 100644
--- a/community/ark/APKBUILD
+++ b/community/ark/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=ark
-pkgver=19.08.2
+pkgver=19.08.3
pkgrel=0
pkgdesc="Graphical file compression/decompression utility with support for multiple formats"
arch="all"
@@ -13,8 +13,15 @@ checkdepends="xvfb-run"
source="https://download.kde.org/stable/applications/$pkgver/src/ark-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -22,11 +29,13 @@ build() {
}
check() {
+ cd "$builddir"/build
# plugins-cliunarchivertest is broken since Qt 5.11
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "plugins-clirartest"
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="c4ae42a68a9f00238de4dcfef066c3e20f9a896fe00473b4db4ca4aadc8db1f63c876a98833799c533962283fe3f64be36e563e5624e0dae1978452438392788 ark-19.08.2.tar.xz"
+sha512sums="2bbbce37e5f892840517688eb4ce78770514eb5c780d34ae3c33c4b4e60cd153ebc190e4613411d5e01f01a78b6a74bad86c79b9efe8a156250c18033a3271cf ark-19.08.3.tar.xz"