aboutsummaryrefslogtreecommitdiffstats
path: root/community/arping/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/arping/APKBUILD')
-rw-r--r--community/arping/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/community/arping/APKBUILD b/community/arping/APKBUILD
index 90d894c8944..3b7f548eea9 100644
--- a/community/arping/APKBUILD
+++ b/community/arping/APKBUILD
@@ -1,32 +1,34 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=arping
-pkgver=2.21
-pkgrel=1
+pkgver=2.24
+pkgrel=0
pkgdesc="An ARP ping utility"
-url="http://www.habets.pp.se/synscan/programs.php?prog=arping"
+url="https://www.habets.pp.se/synscan/programs_arping.html"
arch="all"
license="GPL-2.0-or-later"
depends="!iputils"
makedepends="libnet-dev libpcap-dev"
checkdepends="subunit-dev check-dev"
subpackages="$pkgname-doc"
-source="http://www.habets.pp.se/synscan/files/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
-
-check() {
- cd "$builddir"
- ./src/arping --help > /dev/null
-}
+source="https://www.habets.pp.se/synscan/files/arping-$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure --prefix=/usr
make
}
+
+check() {
+ ./src/arping --help > /dev/null
+}
+
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
+
+ cd "$pkgdir"
+ rm -vr usr/include
}
-sha512sums="0413e87aa9f0664c3e9485c1d8c2fbd2adb322bfc871f9bddf84f458433d7c8c7587ac4b24cff36caff7b966cd9b71a7d8a54ac951723b322a475ac68cf45d47 arping-2.21.tar.gz"
+sha512sums="
+922764936cea7c11f32c495ccbda5fecac073c3b8b4ae221cfafb1f846e52b8461bfd192e29f526f9b84391fc831d3c2aaf629779f6834dfbe4fda5b280bb1a7 arping-2.24.tar.gz
+"