aboutsummaryrefslogtreecommitdiffstats
path: root/community/assimp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/assimp/APKBUILD')
-rw-r--r--community/assimp/APKBUILD34
1 files changed, 21 insertions, 13 deletions
diff --git a/community/assimp/APKBUILD b/community/assimp/APKBUILD
index 05aa81eb5b1..c07c9c358e6 100644
--- a/community/assimp/APKBUILD
+++ b/community/assimp/APKBUILD
@@ -1,28 +1,32 @@
# Contributor: Russ Webber <russ@rw.id.au>
# Maintainer: Russ Webber <russ@rw.id.au>
pkgname=assimp
-pkgver=5.2.3
+pkgver=5.3.1
pkgrel=0
-pkgdesc="Open Asset Import Library imports and exports 3D model formats."
-url="http://www.assimp.org/"
-arch="all !s390x" # fails to build on big-endian
+pkgdesc="Open Asset Import Library imports and exports 3D model formats"
+url="https://www.assimp.org/"
+arch="all"
license="BSD-3-Clause"
makedepends="
cmake
samurai
zlib-dev
"
-subpackages="$pkgname-dev"
-source="https://github.com/assimp/assimp/archive/v$pkgver/assimp-v$pkgver.tar.gz"
+subpackages="$pkgname-dev $pkgname-libs"
+source="https://github.com/assimp/assimp/archive/v$pkgver/assimp-v$pkgver.tar.gz
+ version.patch
+ "
+
+case "$CARCH" in
+s390x)
+ # a few tests fail
+ options="$options !check"
+ ;;
+esac
prepare() {
default_prepare
- # fails for some unknown divine reason
- sed -i \
- -e "/AssimpAPITest_aiQuaternion/d" \
- test/CMakeLists.txt
-
# tests report correct values, but comparison fails
case $CARCH in
x86)
@@ -41,7 +45,10 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
- -DASSIMP_BUILD_TESTS=True \
+ -DASSIMP_IGNORE_GIT_HASH=ON \
+ -DASSIMP_BUILD_ASSIMP_TOOLS=ON \
+ -DASSIMP_BUILD_TESTS="$(want_check && echo ON || echo OFF)" \
+ -DASSIMP_WARNINGS_AS_ERRORS=OFF \
-DASSIMP_BUILD_MINIZIP=True # use vendored fork of minizip
cmake --build build
}
@@ -56,5 +63,6 @@ package() {
}
sha512sums="
-accc1020877b631431bd0bc2de20b530d7e8d234e960904070292a4a08e768c55d1d0cf614c68d38f099fab2d086420c3ffd3f729cb538b169c1275ef0be1eaa assimp-v5.2.3.tar.gz
+49963f84ed0a8145f3af249890a533f0b12f5553ae09581289cb1f20cb49cb1a3ed3f3c4c966ceb43aa897b90deca268aa6554066b2bd34f2ac9c15041420ddb assimp-v5.3.1.tar.gz
+c1b9dd92be4bf0702db25b124e2ffd982ef5cd3054e31c31311facf49ab4f1990b6611e0a0d1ffb62ce610911bffd9664f47109fc2d3ed20ba3051be84a3ed51 version.patch
"