aboutsummaryrefslogtreecommitdiffstats
path: root/community/attica/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/attica/APKBUILD')
-rw-r--r--community/attica/APKBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/community/attica/APKBUILD b/community/attica/APKBUILD
index afeb4443faa..defa6782c45 100644
--- a/community/attica/APKBUILD
+++ b/community/attica/APKBUILD
@@ -1,15 +1,24 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=attica
-pkgver=5.94.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Freedesktop OCS binding for Qt"
url="https://www.kde.org/"
arch="all !armhf" # Blocked by extra-cmake-modules
license="LGPL-2.0-or-later"
-makedepends="qt5-qttools-dev extra-cmake-modules doxygen samurai"
-options="!check" # failing on builders
+makedepends="
+ doxygen
+ extra-cmake-modules
+ qt6-qtbase-dev
+ qt6-qttools-dev
+ samurai
+ "
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/frameworks/attica.git"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/attica-$pkgver.tar.xz"
build() {
@@ -22,8 +31,8 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ # providertest requires network access
+ ctest --test-dir build --output-on-failure -E "providertest"
}
package() {
@@ -31,5 +40,5 @@ package() {
}
sha512sums="
-0c5dd2495f43b2cd4e7bd431619af249a767e5f7add913889dffcf64dc5ef8c4551e789a3a2b1850bb7c4a544144921d562e62580f0ff257b0291521dfdddf56 attica-5.94.0.tar.xz
+25cf795e81e96065c6f25b5dbb77fea93eeb14a3475bc5b61472618d0d8703c5d913742bf7f7058dfb9ade2af414437d7ac18bd90b96c55458c727a0c4087e13 attica-6.1.0.tar.xz
"