aboutsummaryrefslogtreecommitdiffstats
path: root/community/atuin/use-system-tls.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/atuin/use-system-tls.patch')
-rw-r--r--community/atuin/use-system-tls.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/community/atuin/use-system-tls.patch b/community/atuin/use-system-tls.patch
new file mode 100644
index 00000000000..7675eb90e5d
--- /dev/null
+++ b/community/atuin/use-system-tls.patch
@@ -0,0 +1,21 @@
+From: Jakub Jirutka <jakub@jirutka.cz>
+Date: Fri, 13 May 2022 01:42:00 +0200
+Subject: [PATCH] Build with system OpenSSL instead of bundled rusttls
+
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -33,12 +33,12 @@
+
+ [workspace.dependencies.reqwest]
+ version = "0.11"
+-features = ["json", "rustls-tls-native-roots"]
++features = ["json", "default-tls"]
+ default-features = false
+
+ [workspace.dependencies.sqlx]
+ version = "0.6"
+-features = ["runtime-tokio-rustls", "chrono", "postgres"]
++features = ["runtime-tokio-native-tls", "chrono", "postgres"]
+
+ [patch.crates-io]
+ sqlx = { path = "./vendor/sqlx" }