aboutsummaryrefslogtreecommitdiffstats
path: root/community/audacious-plugins/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/audacious-plugins/APKBUILD')
-rw-r--r--community/audacious-plugins/APKBUILD87
1 files changed, 42 insertions, 45 deletions
diff --git a/community/audacious-plugins/APKBUILD b/community/audacious-plugins/APKBUILD
index 9ddfed5573f..774678dec11 100644
--- a/community/audacious-plugins/APKBUILD
+++ b/community/audacious-plugins/APKBUILD
@@ -2,77 +2,74 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Ariadne Conill <ariadne@dereferenced.org>
pkgname=audacious-plugins
-pkgver=4.0.5
-pkgrel=2
+pkgver=4.3.1
+pkgrel=1
pkgdesc="A playlist-oriented media player with multiple interfaces (plugins)"
url="https://audacious-media-player.org/"
arch="all !s390x"
license="BSD-2-Clause AND BSD-3-Clause AND ISC AND GPL-2.0-only AND GPL-2.0-or-later AND GPL-3.0-only AND GPL-3.0-or-later"
depends="audacious"
-install_if="audacious=$pkgver"
+install_if="audacious"
makedepends="
+ alsa-lib-dev
+ audacious-dev
+ autoconf
+ automake
+ curl-dev
dbus-glib-dev
- audacious-dev>=${pkgver%.*}
- libxml2-dev
- mpg123-dev
+ faad2-dev
+ ffmpeg-dev
+ flac-dev
+ lame-dev
+ libcddb-dev
libcdio-dev
libcdio-paranoia-dev
- libcddb-dev
- libxcomposite-dev
- libsamplerate-dev
libcue-dev
libmms-dev
- libsndfile-dev
libnotify-dev
libogg-dev
+ libopenmpt-dev
+ libsamplerate-dev
+ libsndfile-dev
libvorbis-dev
- ffmpeg-dev
- alsa-lib-dev
- pulseaudio-dev
- faad2-dev
+ libxcomposite-dev
+ libxml2-dev
+ meson
+ mpg123-dev
neon-dev
- curl-dev
- wavpack-dev
- lame-dev
- flac-dev
+ pulseaudio-dev
sdl2-dev
- automake
- autoconf
+ wavpack-dev
"
subpackages="$pkgname-dbg $pkgname-lang"
source="http://distfiles.audacious-media-player.org/audacious-plugins-$pkgver.tar.bz2"
options="!check" # No test suite (or any plans for one)
-case "$CTARGET_ARCH" in
- arm*|aarch64) _qtglspectrum="--disable-qtglspectrum" ;;
- *) _qtglspectrum="--enable-qtglspectrum" ;;
-esac
-
-prepare() {
- default_prepare
-
- update_config_sub
- update_config_guess
-}
-
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --disable-gtk \
- --enable-qt \
- $_qtglspectrum
- make
+ case "$CARCH" in
+ arm*|aarch64)
+ local qtgl=false
+ ;;
+ *)
+ local qtgl=true
+ ;;
+ esac
+ abuild-meson \
+ -Db_lto=true \
+ -Dgtk=false \
+ -Dgtk3=false \
+ -Dqt=true \
+ -Dqt6=true \
+ -Dgl-spectrum=$qtgl \
+ . output
+
+ meson compile -C output
}
package() {
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
sha512sums="
-90ab2edbfc797fa835aae9937b5f478a0ca575f31c443d9e8ba7394e1615f605beb417372872874c94d4f804dba7bea9fbae2078e162178386683d8a3e36c108 audacious-plugins-4.0.5.tar.bz2
+ca065b4558406702e4f2aa2ac085ea02d3215e689e09e9c0b6a740970a469297910df52cd222997e8a4206a68d3a064ac3f6d94c6412830ce8bd34a5b42c30da audacious-plugins-4.3.1.tar.bz2
"