aboutsummaryrefslogtreecommitdiffstats
path: root/community/audiocd-kio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/audiocd-kio/APKBUILD')
-rw-r--r--community/audiocd-kio/APKBUILD53
1 files changed, 32 insertions, 21 deletions
diff --git a/community/audiocd-kio/APKBUILD b/community/audiocd-kio/APKBUILD
index 23aa5ef8509..6fa838e137c 100644
--- a/community/audiocd-kio/APKBUILD
+++ b/community/audiocd-kio/APKBUILD
@@ -1,40 +1,51 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=audiocd-kio
-pkgver=19.12.2
-pkgrel=1
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+pkgver=24.02.2
+pkgrel=0
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://www.kde.org/applications/multimedia/"
pkgdesc="Kioslave for accessing audio CDs"
license="GPL-2.0-or-later AND GFDL-1.2-only"
-makedepends="extra-cmake-modules qt5-qtbase-dev kconfig-dev ki18n-dev kdoctools-dev kio-dev kcmutils-dev libkcddb-dev libkcompactdisc-dev cdparanoia-dev flac-dev libvorbis-dev"
+makedepends="
+ cdparanoia-dev
+ extra-cmake-modules
+ flac-dev
+ kcmutils-dev
+ kconfig-dev
+ kdoctools-dev
+ ki18n-dev
+ kio-dev
+ libkcddb-dev
+ libkcompactdisc-dev
+ libvorbis-dev
+ qt6-qtbase-dev
+ samurai
+ "
+_repo_url="https://invent.kde.org/multimedia/audiocd-kio.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/audiocd-kio-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
-
-prepare() {
- default_prepare
-
- mkdir "$builddir"/build
-}
build() {
- cd "$builddir"/build
- cmake "$builddir" \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- make
+ cmake --build build
}
check() {
- cd "$builddir"/build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="2420bc90cedcfd50b4c0d1dd0e442c8c55b014ffdf050880c2f85b15bfbca03ae8cf039ff7736042c72bc209441c44d29a0abd8f534a52838060693b967c3688 audiocd-kio-19.12.2.tar.xz"
+sha512sums="
+1da6fd53fea689dd58794a6190fc0b759feb45bc3fb2cbb0295f8f4207c59c92390341a1d78b516970e51f11c7ed79cd5feb081814ceb9c8d1107a850f29b265 audiocd-kio-24.02.2.tar.xz
+"