aboutsummaryrefslogtreecommitdiffstats
path: root/community/audiocd-kio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/audiocd-kio/APKBUILD')
-rw-r--r--community/audiocd-kio/APKBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/community/audiocd-kio/APKBUILD b/community/audiocd-kio/APKBUILD
index 57e51017331..bea93879bee 100644
--- a/community/audiocd-kio/APKBUILD
+++ b/community/audiocd-kio/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=audiocd-kio
-pkgver=22.04.2
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://www.kde.org/applications/multimedia/"
pkgdesc="Kioslave for accessing audio CDs"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -21,12 +23,12 @@ makedepends="
libkcddb-dev
libkcompactdisc-dev
libvorbis-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
+_repo_url="https://invent.kde.org/multimedia/audiocd-kio.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/audiocd-kio-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
build() {
cmake -B build -G Ninja \
@@ -37,8 +39,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -46,5 +47,5 @@ package() {
}
sha512sums="
-60198a6df3f75adca03bf8287c79b1cf41bf907dd0ef5e97fa880161e38ed47c35080fa76b931d61a103e1f63d008ac099da9c0c53e6e00bb85a6124559b4ecc audiocd-kio-22.04.2.tar.xz
+d0f9f07cd0d06bf98e4460463fc8ac8a250b8736907e0dca34ad00ed97b98d69ee43c5a6226174e959e23499b48e22e22a95b435fcfbb01d18546ef928259f8f audiocd-kio-24.02.1.tar.xz
"