aboutsummaryrefslogtreecommitdiffstats
path: root/community/audiocd-kio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/audiocd-kio/APKBUILD')
-rw-r--r--community/audiocd-kio/APKBUILD24
1 files changed, 13 insertions, 11 deletions
diff --git a/community/audiocd-kio/APKBUILD b/community/audiocd-kio/APKBUILD
index eaab2715920..6fa838e137c 100644
--- a/community/audiocd-kio/APKBUILD
+++ b/community/audiocd-kio/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=audiocd-kio
-pkgver=21.08.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://www.kde.org/applications/multimedia/"
pkgdesc="Kioslave for accessing audio CDs"
license="GPL-2.0-or-later AND GFDL-1.2-only"
@@ -21,23 +23,23 @@ makedepends="
libkcddb-dev
libkcompactdisc-dev
libvorbis-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
+_repo_url="https://invent.kde.org/multimedia/audiocd-kio.git"
source="https://download.kde.org/stable/release-service/$pkgver/src/audiocd-kio-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -45,5 +47,5 @@ package() {
}
sha512sums="
-6f81d3890531bc56c61c1aff9dd15f26f908992ea54b454f0371751897f94f30280388e8f5f8197cc4800f1fcd43541ef6741a318bdea04e2e2ba13addcc2c6d audiocd-kio-21.08.3.tar.xz
+1da6fd53fea689dd58794a6190fc0b759feb45bc3fb2cbb0295f8f4207c59c92390341a1d78b516970e51f11c7ed79cd5feb081814ceb9c8d1107a850f29b265 audiocd-kio-24.02.2.tar.xz
"