aboutsummaryrefslogtreecommitdiffstats
path: root/community/ausweisapp2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ausweisapp2/APKBUILD')
-rw-r--r--community/ausweisapp2/APKBUILD47
1 files changed, 33 insertions, 14 deletions
diff --git a/community/ausweisapp2/APKBUILD b/community/ausweisapp2/APKBUILD
index 26529121811..e2254972f0b 100644
--- a/community/ausweisapp2/APKBUILD
+++ b/community/ausweisapp2/APKBUILD
@@ -1,29 +1,46 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=ausweisapp2
-pkgver=1.22.2
-pkgrel=1
+pkgver=2.1.1
+pkgrel=0
pkgdesc="Official authentication app for German ID card and residence permit"
url="https://www.ausweisapp.bund.de/"
-arch="all !armhf" # missing qt5-qtquickcontrols2
+arch="all"
license="EUPL-1.2"
-depends="pcsc-lite pcsc-cyberjack ccid acsccid"
-makedepends="cmake pkgconf pcsc-lite-dev http-parser-dev openssl1.1-compat-dev
- qt5-qtbase-dev qt5-qtsvg-dev qt5-qtwebsockets-dev qt5-qttools-dev
- qt5-qtdeclarative-dev qt5-qtquickcontrols2-dev"
+depends="
+ acsccid
+ ccid
+ pcsc-cyberjack
+ pcsc-lite
+ "
+makedepends="
+ cmake
+ http-parser-dev
+ openssl-dev
+ pcsc-lite-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ qt6-qtscxml-dev
+ qt6-qtsvg-dev
+ qt6-qttools-dev
+ qt6-qtwebsockets-dev
+ qt6-qtwebsockets
+ samurai
+ "
subpackages="$pkgname-doc"
-source="https://github.com/Governikus/AusweisApp2/releases/download/$pkgver/AusweisApp2-$pkgver.tar.gz"
+source="https://github.com/Governikus/AusweisApp2/releases/download/$pkgver/AusweisApp-$pkgver.tar.gz
+ "
options="!check" # no upstream tests in release build
-builddir="$srcdir/AusweisApp2-$pkgver"
+builddir="$srcdir/AusweisApp-$pkgver"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ cmake_crossopts="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
- $CMAKE_CROSSOPTS .
+ $cmake_crossopts .
cmake --build build
}
@@ -31,4 +48,6 @@ package() {
DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="c33c049e7d90b40a7f4942fca90c78374289bd402939162ba30a025b7e47188f4e50a2498909be91ecd4ae2a658ca4742d05c00426c5cdfabbf1deb846a70270 AusweisApp2-1.22.2.tar.gz"
+sha512sums="
+f2cc9de898c3b2e61eb9ac208a21d60708aceeeb79d73f0382bc4b68e4011178217594bd99ac24b07d0d3fbd80b46e5c3ddc6c76bb764e24dc473197f4e1d4c9 AusweisApp-2.1.1.tar.gz
+"