aboutsummaryrefslogtreecommitdiffstats
path: root/community/avizo/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/avizo/APKBUILD')
-rw-r--r--community/avizo/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/community/avizo/APKBUILD b/community/avizo/APKBUILD
new file mode 100644
index 00000000000..dc96e2da2f4
--- /dev/null
+++ b/community/avizo/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=avizo
+pkgver=1.2.1
+pkgrel=2
+pkgdesc="A neat notification daemon"
+url="https://github.com/misterdanb/avizo"
+arch="all"
+license="GPL-3.0"
+makedepends="
+ gobject-introspection-dev
+ gtk+3.0-dev
+ gtk-layer-shell-dev
+ meson
+ vala
+ "
+subpackages="$pkgname-scripts::noarch"
+source="https://github.com/misterdanb/avizo/archive/$pkgver/$pkgname-$pkgver.tar.gz
+ replace-pactl-with-pamixer.patch
+ unbundle-images.patch
+ "
+options="!check" # no tests provided
+
+build() {
+ abuild-meson . output
+ meson compile -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+scripts() {
+ pkgdesc="Scripts to control sound volume and display backlight integrated with Avizo"
+ depends="$pkgname brightnessctl pamixer"
+
+ amove usr/bin/lightctl
+ amove usr/bin/volumectl
+}
+
+sha512sums="
+83880a176fe3a2e900a6a0bf3d6cd4bb725421017a8edd0e118d089bf480bcc3733738d56e1ce25bd55cdbc5a2bccacb3419233b8d27a2438b998703a962d247 avizo-1.2.1.tar.gz
+10370a2fb58c3ec77f6e62b5cda0eb3db4b70992c125925cc5a52d64f535039ced3c9ea5b0830fe5c899ca12c07da757679c2ae232f62ebd77ec121fcbebad3c replace-pactl-with-pamixer.patch
+668d49d8543b6e4c789e52b8883fe2bf938a7b19e5c126859151b71ae1ab943606137824cfe321e373d1a2eb2b85ecba13c9b8ab4d2dea95d3d5ebb9dde5cec1 unbundle-images.patch
+"