aboutsummaryrefslogtreecommitdiffstats
path: root/community/avizo/pr-28.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/avizo/pr-28.patch')
-rw-r--r--community/avizo/pr-28.patch80
1 files changed, 0 insertions, 80 deletions
diff --git a/community/avizo/pr-28.patch b/community/avizo/pr-28.patch
deleted file mode 100644
index bf1b015e28a..00000000000
--- a/community/avizo/pr-28.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-Patch-Source: https://github.com/misterdanb/avizo/pull/28
-From: Jakub Jirutka <jakub@jirutka.cz>
-Date: Sun, 9 Jan 2022 03:28:34 +0100
-Subject: [PATCH] Fix --version and inject version number from meson.build
-
-diff --git a/meson.build b/meson.build
-index 113c0db..1c789be 100644
---- a/meson.build
-+++ b/meson.build
-@@ -1,5 +1,5 @@
- project('avizo', 'c', 'vala',
-- version: '0.0',
-+ version: '1.1',
- license: 'GPLv3+')
-
- add_project_arguments(['--target-glib=2.38'],
-diff --git a/src/avizo_client.vala b/src/avizo_client.vala
-index 943502d..849bb03 100644
---- a/src/avizo_client.vala
-+++ b/src/avizo_client.vala
-@@ -21,8 +21,6 @@ interface AvizoService : GLib.Object
-
- public class AvizoClient : GLib.Application
- {
-- private static string VERSION = "1.0";
--
- private AvizoService _service = null;
-
- private static bool _show_version = false;
-@@ -114,7 +112,7 @@ public class AvizoClient : GLib.Application
-
- if (_show_version)
- {
-- print(@"noti-client $VERSION)\n");
-+ print(@"avizo-client $(Config.VERSION)\n");
-
- return 0;
- }
-diff --git a/src/config.vala.in b/src/config.vala.in
-new file mode 100644
-index 0000000..4f2ca6d
---- /dev/null
-+++ b/src/config.vala.in
-@@ -0,0 +1,3 @@
-+namespace Config {
-+ public const string VERSION = @VERSION@;
-+}
-diff --git a/src/meson.build b/src/meson.build
-index 9236d03..ca91384 100644
---- a/src/meson.build
-+++ b/src/meson.build
-@@ -3,6 +3,14 @@ gtk_dep = dependency('gtk+-3.0')
- gobject_dep = dependency('gobject-2.0')
- gobject_introspection_dep = dependency('gobject-introspection-1.0')
-
-+config_data = configuration_data()
-+config_data.set_quoted('VERSION', meson.project_version())
-+config_vala = configure_file(
-+ input : 'config.vala.in',
-+ output : 'config.vala',
-+ configuration : config_data
-+)
-+
- app_sources_service = files(
- 'avizo_service.vala'
- )
-@@ -12,11 +20,13 @@ app_sources_client = files(
- )
-
- sources_service = [
-+ config_vala,
- app_resources_service,
- app_sources_service
- ]
-
- sources_client = [
-+ config_vala,
- app_sources_client
- ]
-