aboutsummaryrefslogtreecommitdiffstats
path: root/community/avr-libc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/avr-libc/APKBUILD')
-rw-r--r--community/avr-libc/APKBUILD35
1 files changed, 17 insertions, 18 deletions
diff --git a/community/avr-libc/APKBUILD b/community/avr-libc/APKBUILD
index 84226f190ec..b68b9831ef3 100644
--- a/community/avr-libc/APKBUILD
+++ b/community/avr-libc/APKBUILD
@@ -1,32 +1,29 @@
# Contributor: Stefan Wagner <stw@bit-strickerei.de>
# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=avr-libc
-pkgver=2.0.0
-_ubuntupkgver=2.0.0
-_atmelver=3.6.1
+pkgver=2.1.0
+_atmelver=3.7.0.1796
pkgrel=4
pkgdesc="The C runtime library for the AVR family of microcontrollers"
-url="https://savannah.nongnu.org/projects/avr-libc/"
+url="https://github.com/avrdudes/avr-libc"
depends="gcc-avr"
makedepends="autoconf automake"
-arch="all"
-license="BSD 3-Clause"
+arch="x86_64 ppc64le aarch64 x86"
+license="BSD-3-Clause"
subpackages="$pkgname-doc"
+builddir="$srcdir/$pkgname-$pkgname-${pkgver//./_}-release"
source="
- https://download.savannah.gnu.org/releases/avr-libc/avr-libc-$pkgver.tar.bz2
- http://archive.ubuntu.com/ubuntu/pool/universe/a/avr-libc/avr-libc_$_ubuntupkgver+Atmel$_atmelver.orig.tar.gz
+ avr-libc-$pkgver.tar.gz::https://github.com/avrdudes/avr-libc/archive/refs/tags/avr-libc-${pkgver//./_}-release.tar.gz
+ https://ww1.microchip.com/downloads/aemDocuments/documents/DEV/ProductDocuments/SoftwareTools/avr8-gnu-toolchain-$_atmelver-linux.any.x86_64.tar.gz
"
prepare() {
default_prepare
- # Hack: Allow config.guess and config.sub to be updated
- chmod +w config.guess config.sub
- update_config_guess
- update_config_sub
- # Update vendor header files. Downloading those from Microchip requires
- # setting up an account and log in. So instead we download them from Ubuntu
- # source mirror.
- cp ../avr-libc-$_ubuntupkgver+Atmel$_atmelver/avr/*.h include/avr/
+
+ # Updating I/O header files from Atmel toolchain
+ find ../avr8-gnu-toolchain-linux_x86_64/avr/include/avr \
+ -name 'io*.h' \
+ -exec cp {} include/avr/ \;
}
build() {
@@ -46,5 +43,7 @@ package() {
fi
}
-sha512sums="fc8d062043d633350dbe05978935dcb8028257a4f1013f246af9658aef0671def19ac11577d1ee9302df68df1b8cf030b22441d96852e185db212263aacabea6 avr-libc-2.0.0.tar.bz2
-ffb0009f99ddd51dadf998e5d67d79ba192740e0aaa32a2c154b16985a07d3a267ffc58cbe70cb201550ea49540617b7985ea9a100bd0330d1602ba190018d1e avr-libc_2.0.0+Atmel3.6.1.orig.tar.gz"
+sha512sums="
+b9b5702e3770fb76a9b6b405a744120c2b127032424caff6e002b4d21a04a293607da2bb36cb797cbcdf0209e851e858a192d9b2c812e6c6bf8e54ec18ae1beb avr-libc-2.1.0.tar.gz
+25739df6277f644cac00460f5ac42707f43a841902f23fb7632c9c7aeec89302340b3cc7c4e90a994e400a1d6f6f37804fee0c5cd95320e9d725a24de8127a1f avr8-gnu-toolchain-3.7.0.1796-linux.any.x86_64.tar.gz
+"