aboutsummaryrefslogtreecommitdiffstats
path: root/community/ayatana-indicator-notifications/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/ayatana-indicator-notifications/APKBUILD')
-rw-r--r--community/ayatana-indicator-notifications/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/ayatana-indicator-notifications/APKBUILD b/community/ayatana-indicator-notifications/APKBUILD
new file mode 100644
index 00000000000..8056ea8c4d9
--- /dev/null
+++ b/community/ayatana-indicator-notifications/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Luca Weiss <luca@z3ntu.xyz>
+# Maintainer: Luca Weiss <luca@z3ntu.xyz>
+pkgname=ayatana-indicator-notifications
+pkgver=23.10.1
+pkgrel=0
+pkgdesc="Ayatana Indicator Notifications Service"
+url="https://github.com/AyatanaIndicators/ayatana-indicator-notifications"
+arch="all"
+license="GPL-3.0-only"
+makedepends="
+ cmake
+ cmake-extras
+ glib-dev
+ intltool
+ libayatana-common-dev
+ samurai
+ "
+subpackages="$pkgname-lang"
+source="https://github.com/AyatanaIndicators/ayatana-indicator-notifications/archive/$pkgver/ayatana-indicator-notifications-$pkgver.tar.gz"
+options="!check" # no tests
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake -B build -G Ninja \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
+ $CMAKE_CROSSOPTS .
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+72be9902b6649160b01051dacfd0e126e0e67b5f07ea989b9268acd643a17059c7bb7a807ebb6729fb32de0a4ef3e93c219568e1b19512d3616c7d69288fcfcb ayatana-indicator-notifications-23.10.1.tar.gz
+"