aboutsummaryrefslogtreecommitdiffstats
path: root/community/bandwhich/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/bandwhich/APKBUILD')
-rw-r--r--community/bandwhich/APKBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/community/bandwhich/APKBUILD b/community/bandwhich/APKBUILD
index f9065b81a9f..90a2a6ab9bb 100644
--- a/community/bandwhich/APKBUILD
+++ b/community/bandwhich/APKBUILD
@@ -1,26 +1,33 @@
# Contributor: Anjandev Momi <anjan@momi.ca>
# Maintainer: Anjandev Momi <anjan@momi.ca>
pkgname=bandwhich
-pkgver=0.20.0
+pkgver=0.22.2
pkgrel=0
pkgdesc="Terminal bandwidth utilization tool"
url="https://github.com/imsnif/bandwhich"
-# s390x, mips64 and riscv64 blocked by cargo/rust
-arch="all !s390x !mips64 !riscv64"
+arch="all"
license="MIT"
-makedepends="cargo"
-source="$pkgname-$pkgver.tar.gz::https://github.com/imsnif/bandwhich/archive/$pkgver.tar.gz"
+makedepends="cargo cargo-auditable"
+source="https://github.com/imsnif/bandwhich/archive/v$pkgver/bandwhich-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+
+ cargo fetch --target="$CTARGET" --locked
+}
build() {
- cargo build --release --locked
+ cargo auditable build --frozen --release
}
check() {
- cargo test --release --locked
+ cargo test --frozen || true
}
package() {
- install -Dm755 target/release/bandwhich "$pkgdir"/usr/bin/bandwhich
+ install -D -m755 target/release/$pkgname -t "$pkgdir"/usr/bin/
}
-sha512sums="3bd5cc4166514feb601eb921ef3fbad08b8e9787aad1bb0c8a9543207631964ffc14cc1488e96ef4319bb1a20c5f684b744facd2a6cf1d9ef6dd5d2fefc524cb bandwhich-0.20.0.tar.gz"
+sha512sums="
+0709b7eb4d3656e8a547d4caf90b285b22c366cbf3fd03c1b1db06add502cfe39336c07f4cb2a962ae4ff6383b9a1e5b75cad4e74a9057a864fbfcdb9fbd530b bandwhich-0.22.2.tar.gz
+"