aboutsummaryrefslogtreecommitdiffstats
path: root/community/bareos/disable-systemtest-minio.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/bareos/disable-systemtest-minio.patch')
-rw-r--r--community/bareos/disable-systemtest-minio.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/community/bareos/disable-systemtest-minio.patch b/community/bareos/disable-systemtest-minio.patch
new file mode 100644
index 00000000000..bfde3ddd5b1
--- /dev/null
+++ b/community/bareos/disable-systemtest-minio.patch
@@ -0,0 +1,17 @@
+diff --git a/systemtests/CMakeLists.txt b/systemtests/CMakeLists.txt
+index 6ddf39b..dcd6d66 100644
+--- a/systemtests/CMakeLists.txt
++++ b/systemtests/CMakeLists.txt
+@@ -192,12 +192,6 @@ execute_process(
+ RESULT_VARIABLE RESULT_GENERATE_MINIO_CERTS
+ OUTPUT_QUIET ERROR_QUIET
+ )
+-if(NOT "${RESULT_GENERATE_MINIO_CERTS}" STREQUAL "0")
+- message(
+- FATAL_ERROR
+- "Creation of certificates failed: ${RESULT_GENERATE_MINIO_CERTS} ${CMAKE_BINARY_DIR}"
+- )
+-endif()
+
+ configure_file(
+ "CTestCustom.cmake.in" "${CMAKE_BINARY_DIR}/CTestCustom.cmake" @ONLY