aboutsummaryrefslogtreecommitdiffstats
path: root/community/bareos/disable-werror.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/bareos/disable-werror.patch')
-rw-r--r--community/bareos/disable-werror.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/community/bareos/disable-werror.patch b/community/bareos/disable-werror.patch
new file mode 100644
index 00000000000..182ae431bc0
--- /dev/null
+++ b/community/bareos/disable-werror.patch
@@ -0,0 +1,15 @@
+diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
+index 489b282..20647c4 100644
+--- a/core/CMakeLists.txt
++++ b/core/CMakeLists.txt
+@@ -394,8 +394,8 @@ if(developer)
+ add_definitions("-DDEVELOPER=1")
+ endif()
+
+-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror -Wall -Wextra")
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Wall -Wextra")
++set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra")
+
+ include(BareosSetVariableDefaults)
+ option(ENABLE_BCONSOLE "Build bconsole binary" ON)