aboutsummaryrefslogtreecommitdiffstats
path: root/community/basu/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/basu/APKBUILD')
-rw-r--r--community/basu/APKBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/community/basu/APKBUILD b/community/basu/APKBUILD
index b5e35d6680c..fef21e702cf 100644
--- a/community/basu/APKBUILD
+++ b/community/basu/APKBUILD
@@ -1,26 +1,23 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=basu
-pkgver=0.2.0
-pkgrel=1
+pkgver=0.2.1
+pkgrel=2
pkgdesc="The sd-bus library, extracted from systemd"
url="https://sr.ht/~emersion/basu/"
license="LGPL-2.1-or-later"
arch="all"
makedepends="audit-dev gperf libcap-dev meson"
subpackages="$pkgname-static $pkgname-dev"
-# NOTE: Switch to new upstream repo at sr.ht as soon as release tags are available there.
-source="https://github.com/emersion/basu/archive/v$pkgver/basu-$pkgver.tar.gz
- allow-both-shared-and-static-lib.patch
- link-basuctl-with-libbasu-dynamically.patch
- "
+source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~emersion/basu/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-v$pkgver"
build() {
abuild-meson \
-Dsystem-bus-address="unix:path=/run/dbus/system_bus_socket" \
-Ddefault_library=both \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
@@ -32,7 +29,5 @@ package() {
}
sha512sums="
-dbc2f72b6e1a880fa41fe6067a38a301f456e4305dae6eb4d465089d7d9c2f629677ba23752b3e1a1fd476cb440db01ef3a218c1c976f38d0058eed584c80165 basu-0.2.0.tar.gz
-ce3edb36ec08012deeab1616a1df20f0bcbb7157a0b544b188ee1ccbe0f2cbcff8dd23b7f36bc1f75c993ff8409bd57d9bbe3bde1f4ba575b669bbe085f97cb3 allow-both-shared-and-static-lib.patch
-172c6e519fcee29edff010423487a93f4e7e144836bf0d1e92181b5518e6a1c4e477f5d971e7cf93314b69d33674a5ae69cd963f0dd876496c34dd1fb0047020 link-basuctl-with-libbasu-dynamically.patch
+b1f6a35e4d93d099c5c92a8ea68f8a93429a614f1a63de7346e256437525bee5b87c1a5ad2e0dad2ff0bdc88b525cf1931f048e032bd1f1ff007b4d5eee90c59 basu-0.2.1.tar.gz
"