aboutsummaryrefslogtreecommitdiffstats
path: root/community/beancount/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/beancount/APKBUILD')
-rw-r--r--community/beancount/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/community/beancount/APKBUILD b/community/beancount/APKBUILD
index 923a182dd25..f2309977396 100644
--- a/community/beancount/APKBUILD
+++ b/community/beancount/APKBUILD
@@ -1,17 +1,18 @@
# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=beancount
-pkgver=2.3.4
-pkgrel=2
+pkgver=2.3.5
+pkgrel=6
pkgdesc="Double-Entry Accounting from Text Files"
-url="http://furius.ca/beancount/"
+url="https://beancount.github.io/"
arch="all !ppc64le" # limited by py3-grpcio
license="GPL-2.0-only"
depends="python3 py3-dateutil py3-ply py3-bottle py3-lxml py3-magic
py3-beautifulsoup4 py3-requests py3-chardet py3-pytest
py3-google-api-python-client"
makedepends="python3-dev py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://github.com/beancount/beancount/archive/$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver-meow.tar.gz::https://github.com/beancount/beancount/archive/$pkgver.tar.gz"
options="!check"
build() {
@@ -20,7 +21,7 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
check() {
@@ -31,4 +32,6 @@ check() {
--deselect=beancount/ingest/importers/fileonly_test.py::TestFileOnly::test_match
}
-sha512sums="6ec63b48c9fae614a789e6a3e8622bf2c05c165b76ceadc64b223f9dc2629abebaa67d8185840ef9ada996fd38a24899893ac84903ad051b41e0c64b2c279bf8 beancount-2.3.4.tar.gz"
+sha512sums="
+a3f1343ddf54cf13ef60802de210dc89e9ae202bca802b1b4eb532588f71d51fa4b71672b4e6a1e9676135d406fd55c421b80c439fa2f5f4279e61211f558a2a beancount-2.3.5-meow.tar.gz
+"