aboutsummaryrefslogtreecommitdiffstats
path: root/community/beancount/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/beancount/APKBUILD')
-rw-r--r--community/beancount/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/beancount/APKBUILD b/community/beancount/APKBUILD
index 487ea497af7..14c64b6a99a 100644
--- a/community/beancount/APKBUILD
+++ b/community/beancount/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=beancount
pkgver=2.3.5
-pkgrel=3
+pkgrel=7
pkgdesc="Double-Entry Accounting from Text Files"
url="https://beancount.github.io/"
arch="all !ppc64le" # limited by py3-grpcio
@@ -11,6 +11,7 @@ depends="python3 py3-dateutil py3-ply py3-bottle py3-lxml py3-magic
py3-beautifulsoup4 py3-requests py3-chardet py3-pytest
py3-google-api-python-client"
makedepends="python3-dev py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver-meow.tar.gz::https://github.com/beancount/beancount/archive/$pkgver.tar.gz"
options="!check"
@@ -20,7 +21,7 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
check() {