aboutsummaryrefslogtreecommitdiffstats
path: root/community/bfs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/bfs/APKBUILD')
-rw-r--r--community/bfs/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/bfs/APKBUILD b/community/bfs/APKBUILD
new file mode 100644
index 00000000000..08fe9da8554
--- /dev/null
+++ b/community/bfs/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: dai9ah <dai9ah@protonmail.com>
+# Maintainer: dai9ah <dai9ah@protonmail.com>
+pkgname=bfs
+pkgver=2.1
+pkgrel=0
+pkgdesc="Breadth-first variant of the UNIX find command"
+url="https://github.com/tavianator/bfs"
+arch="all"
+license="0BSD"
+makedepends="acl-dev libcap-dev linux-headers attr-dev"
+checkdepends="bash acl"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tavianator/bfs/archive/$pkgver.tar.gz
+ "
+
+build() {
+ make
+}
+
+check() {
+ TEST_FLAGS="--verbose" make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="bfbb2f1664c2f0718c125ae7ec6cccede3c28e2f117e7c6ae2ec370ed9dc3e69d688498765089670fe784518ec65a1bae6151ddd40010873854d5f8206359446 bfs-2.1.tar.gz"