aboutsummaryrefslogtreecommitdiffstats
path: root/community/bitcoin
diff options
context:
space:
mode:
Diffstat (limited to 'community/bitcoin')
-rw-r--r--community/bitcoin/APKBUILD10
-rw-r--r--community/bitcoin/wallet-unbreak-with-boost-1.72.patch24
2 files changed, 29 insertions, 5 deletions
diff --git a/community/bitcoin/APKBUILD b/community/bitcoin/APKBUILD
index a230c6f4050..ae9b5a08319 100644
--- a/community/bitcoin/APKBUILD
+++ b/community/bitcoin/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=bitcoin
-pkgver=0.18.1
+pkgver=0.19.0.1
_ver=${pkgver/_/}
-pkgrel=6
+pkgrel=0
pkgdesc="Decentralized P2P electronic cash system"
url="https://www.bitcoin.org"
arch="all !armhf"
@@ -15,7 +15,7 @@ subpackages="$pkgname-dev $pkgname-qt $pkgname-cli $pkgname-tx $pkgname-tests $p
$pkgname-doc $pkgname-openrc"
source="$pkgname-$_ver.tar.gz::https://github.com/bitcoin/bitcoin/archive/v${_ver}.tar.gz
ssize_t.patch
- skip-fs-test-utf8.patch
+ wallet-unbreak-with-boost-1.72.patch
$pkgname.initd
$pkgname.conf
"
@@ -89,8 +89,8 @@ check() {
make check
}
-sha512sums="5fe10f51d1e3119a6e4f522c945ca6d280298c326d4bf4ab996bf6db79ddd1e751fa91efc7c6517083a861b1639ff529effd7cd7d0401c85a3b93d46a6bb38ee bitcoin-0.18.1.tar.gz
+sha512sums="e8c1f22a604ffab04cbcabb344f5e8933d1c54413e4e84cbeff71f7ea5ba31fe9472aa3f684a7d02081c3eb2543524fb07aa97f130a4a22c8a6776b531d2b986 bitcoin-0.19.0.1.tar.gz
98aa5ad81bdb4ae961b791bc978c39117cdf2d83c2181f92bebbb0db107d9b6e86eda265fb3f93ff8a5ca8a7754d7148818b98095d57201dff9363d60b97e7dd ssize_t.patch
-6856e38efbe289e64329c80de9e8489ffbdd8c6eda0f3424fe3922fc765afd90b2915cd4f23abd5bdb72e1882871b1c2fde846ced06e60963dcbdc7aad2844c0 skip-fs-test-utf8.patch
+840c21ec405e5b326b6042addfe49f456aeb3d8fdbb6104fd9c72043f681c19373eadc5c7a215f70669d76e4148931f572e9b3769a8f03e5aa82d98d732df315 wallet-unbreak-with-boost-1.72.patch
71e5f3b5079a22b6ddecfad89363fc642d5ea7da18f1203057f626d214734467f4b933b839c269401be7af2c3dcc01afcb3b98198b7d580c56d8740b34451558 bitcoin.initd
a31210d8db76c5a9b614a6de756c1678c0344898565ac3e5d6a34ac1bed66aec4964f1dc874294bc978f53b0e961df921655f7309df19b66c90aa6bd40379a09 bitcoin.conf"
diff --git a/community/bitcoin/wallet-unbreak-with-boost-1.72.patch b/community/bitcoin/wallet-unbreak-with-boost-1.72.patch
new file mode 100644
index 00000000000..fe70adba573
--- /dev/null
+++ b/community/bitcoin/wallet-unbreak-with-boost-1.72.patch
@@ -0,0 +1,24 @@
+From a64e97dd476bda7c7981979d045b0d06d6f7ce47 Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Mon, 2 Dec 2019 19:55:10 +0000
+Subject: [PATCH] wallet: unbreak with boost 1.72
+
+wallet/walletutil.cpp:77:23: error: no member named 'level' in 'boost::filesystem::recursive_directory_iterator'
+ } else if (it.level() == 0 && it->symlink_status().type() == fs::regular_file && IsBerkeleyBtree(it...
+ ~~ ^
+---
+ src/fs.h | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/fs.h b/src/fs.h
+index c713297d6ef0..8af81f173bdf 100644
+--- a/src/fs.h
++++ b/src/fs.h
+@@ -11,7 +11,6 @@
+ #include <ext/stdio_filebuf.h>
+ #endif
+
+-#define BOOST_FILESYSTEM_NO_DEPRECATED
+ #include <boost/filesystem.hpp>
+ #include <boost/filesystem/fstream.hpp>
+