aboutsummaryrefslogtreecommitdiffstats
path: root/community/blanket/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/blanket/APKBUILD')
-rw-r--r--community/blanket/APKBUILD27
1 files changed, 20 insertions, 7 deletions
diff --git a/community/blanket/APKBUILD b/community/blanket/APKBUILD
index 7dbfa9eea4b..7f629089816 100644
--- a/community/blanket/APKBUILD
+++ b/community/blanket/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: mio <miyopan@e.email>
# Maintainer: mio <miyopan@e.email>
pkgname=blanket
-pkgver=0.6.0
+pkgver=0.7.0
pkgrel=0
pkgdesc="Listen to different sounds to improve focus and increase productivity"
url="https://github.com/rafaelmardojai/blanket"
@@ -9,25 +9,38 @@ license="GPL-3.0-or-later"
# s390x: limited by libhandy
# riscv64: limited by gst-plugins-bad
arch="noarch !s390x !riscv64"
-depends="gst-plugins-bad gst-plugins-base gst-plugins-good libadwaita
- python3 py3-gst py3-gobject3"
-makedepends="appstream-glib-dev meson"
+depends="
+ desktop-file-utils
+ gst-plugins-bad
+ gst-plugins-base
+ gst-plugins-good
+ libadwaita
+ python3
+ py3-gst
+ py3-gobject3
+ "
+makedepends="
+ appstream-glib-dev
+ blueprint-compiler
+ meson
+ "
subpackages="$pkgname-lang"
source="https://github.com/rafaelmardojai/blanket/archive/$pkgver/blanket-$pkgver.tar.gz"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
+ install -Dm0644 COPYING "$pkgdir"/usr/share/licenses/blanket/COPYING
}
sha512sums="
-8269f6f4e5f805bbb52ca06035d469765c3115f841a8b57fda4db9c387ab50db5207ee57cd329173ce0f3e41abfc459e76af615fbb6f979f8e911ee73f74e861 blanket-0.6.0.tar.gz
+dc415b02deec8a898b626ed295b7a95c9b9b06bc0ad7bb86f329f1ea31d8d6fabf78e59d01091efa03f032b3ace489d9dfb47c87bd8c57f925a4ca529de42f1d blanket-0.7.0.tar.gz
"