aboutsummaryrefslogtreecommitdiffstats
path: root/community/bluedevil/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/bluedevil/APKBUILD')
-rw-r--r--community/bluedevil/APKBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/community/bluedevil/APKBUILD b/community/bluedevil/APKBUILD
index 025b88528c2..41252409d63 100644
--- a/community/bluedevil/APKBUILD
+++ b/community/bluedevil/APKBUILD
@@ -1,34 +1,38 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=bluedevil
-pkgver=5.25.3
+pkgver=6.0.3
pkgrel=0
pkgdesc="Integrate the Bluetooth technology within KDE workspace and applications"
-# armhf blocked by qt5-qtdeclarative
+# armhf blocked by qt6-qtdeclarative
arch="all !armhf"
url="https://kde.org/plasma-desktop/"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND ( LGPL-2.1-only OR LGPL-3.0-only )"
depends="
bluez
- bluez-obexd
kded
+ obexd
"
makedepends="
bluez-qt-dev
extra-cmake-modules
+ kcmutils-dev
kcoreaddons-dev
kdbusaddons-dev
- kded
kded-dev
+ kdoctools-dev
ki18n-dev
kiconthemes-dev
kio-dev
knotifications-dev
kwidgetsaddons-dev
kwindowsystem-dev
- plasma-framework-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ libplasma-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
samurai
shared-mime-info
"
@@ -37,8 +41,9 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/bluedevil-$pkgver.tar.xz"
-subpackages="$pkgname-lang"
+subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/bluedevil.git"
+source="https://download.kde.org/stable/plasma/$pkgver/bluedevil-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -49,8 +54,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -58,5 +62,5 @@ package() {
}
sha512sums="
-84142a8224f5219d6f57f0d3ad13094e8db44742caee7aef24262c1fb41584d12393286cafd37e5e26c80078f6eb959a55661e22890268fdb0c284ed72f0ce3e bluedevil-5.25.3.tar.xz
+9b02d3148f74145c1e367e364b2aa2c99b97f293b91dcc9adf21f6d95c480a884fc3febfedf4feb4643916df105f0c1fc4d93a911440ead9272b5d778f7d812d bluedevil-6.0.3.tar.xz
"