aboutsummaryrefslogtreecommitdiffstats
path: root/community/bluedevil/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/bluedevil/APKBUILD')
-rw-r--r--community/bluedevil/APKBUILD40
1 files changed, 22 insertions, 18 deletions
diff --git a/community/bluedevil/APKBUILD b/community/bluedevil/APKBUILD
index bffa8ab8a49..41252409d63 100644
--- a/community/bluedevil/APKBUILD
+++ b/community/bluedevil/APKBUILD
@@ -1,35 +1,39 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-plasma
pkgname=bluedevil
-pkgver=5.22.5
+pkgver=6.0.3
pkgrel=0
pkgdesc="Integrate the Bluetooth technology within KDE workspace and applications"
-# armhf blocked by qt5-qtdeclarative
-# armhf, s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+# armhf blocked by qt6-qtdeclarative
+arch="all !armhf"
url="https://kde.org/plasma-desktop/"
-license="GPL-2.0-or-later AND LGPL-2.0-or-later AND (LGPL-2.1-only OR LGPL-3.0-only)"
+license="GPL-2.0-or-later AND LGPL-2.0-or-later AND ( LGPL-2.1-only OR LGPL-3.0-only )"
depends="
bluez
- bluez-obexd
kded
+ obexd
"
makedepends="
bluez-qt-dev
extra-cmake-modules
+ kcmutils-dev
kcoreaddons-dev
kdbusaddons-dev
- kded
kded-dev
+ kdoctools-dev
ki18n-dev
kiconthemes-dev
kio-dev
knotifications-dev
kwidgetsaddons-dev
kwindowsystem-dev
- plasma-framework-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ libplasma-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ samurai
shared-mime-info
"
@@ -37,20 +41,20 @@ case "$pkgver" in
*.90*) _rel=unstable;;
*) _rel=stable;;
esac
-source="https://download.kde.org/$_rel/plasma/$pkgver/bluedevil-$pkgver.tar.xz"
-subpackages="$pkgname-lang"
+subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/plasma/bluedevil.git"
+source="https://download.kde.org/stable/plasma/$pkgver/bluedevil-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -58,5 +62,5 @@ package() {
}
sha512sums="
-bd92fb1bd55f29916a5e4818785e9be43f7eec01bb5ec9ac35ffe5a8e20ac11079261f46f96a7e60d2f6c5b9b1a06773de2bd525f796d4e0d651edc5056202ab bluedevil-5.22.5.tar.xz
+9b02d3148f74145c1e367e364b2aa2c99b97f293b91dcc9adf21f6d95c480a884fc3febfedf4feb4643916df105f0c1fc4d93a911440ead9272b5d778f7d812d bluedevil-6.0.3.tar.xz
"