aboutsummaryrefslogtreecommitdiffstats
path: root/community/blueprint-compiler/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/blueprint-compiler/APKBUILD')
-rw-r--r--community/blueprint-compiler/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/community/blueprint-compiler/APKBUILD b/community/blueprint-compiler/APKBUILD
index 31ce2a3f18d..9e1298d1dd4 100644
--- a/community/blueprint-compiler/APKBUILD
+++ b/community/blueprint-compiler/APKBUILD
@@ -1,37 +1,40 @@
# Contributor: Newbyte <newbie13xd@gmail.com>
# Maintainer: Newbyte <newbie13xd@gmail.com>
pkgname=blueprint-compiler
-pkgver=0.2.0
-pkgrel=0
+pkgver=0.12.0
+pkgrel=1
pkgdesc="Markup language for GTK user interfaces"
url="https://jwestman.pages.gitlab.gnome.org/blueprint-compiler"
-arch="noarch !riscv64 !s390x"
+arch="noarch"
license="LGPL-3.0-or-later"
depends="
gobject-introspection-dev
gtk4.0
+ libadwaita
python3
py3-gobject3
"
+depends_dev="$pkgname=$pkgver-r$pkgrel"
makedepends="meson"
-checkdepends="gtk4.0-dev"
-subpackages="$pkgname-dev"
+checkdepends="cage-run"
+subpackages="$pkgname-dev $pkgname-pyc"
source="https://gitlab.gnome.org/jwestman/blueprint-compiler/-/archive/v$pkgver/blueprint-compiler-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ cage-run meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
+ python3 -m compileall -fq "$pkgdir"/usr/lib/python*
}
sha512sums="
-d8acdc0f31005215e8945d6b330cce0903d06ad849258a2e2819529908ac864190b8b653ddf0ffd8ff36e4e958711c8a07269eb424ec32a3800faa29af8edb85 blueprint-compiler-v0.2.0.tar.gz
+b9f5e43a34b08bb2708d39e8820e7fe2274bdca3e0e14d290f6c872e070b7f9559c6315579b24da80e7a9115bb64da7d986abc5d520644ce3bedc82fa0a1b4c9 blueprint-compiler-v0.12.0.tar.gz
"