aboutsummaryrefslogtreecommitdiffstats
path: root/community/bluez-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/bluez-qt/APKBUILD')
-rw-r--r--community/bluez-qt/APKBUILD41
1 files changed, 30 insertions, 11 deletions
diff --git a/community/bluez-qt/APKBUILD b/community/bluez-qt/APKBUILD
index 8a48222e7c4..67244b806a5 100644
--- a/community/bluez-qt/APKBUILD
+++ b/community/bluez-qt/APKBUILD
@@ -1,30 +1,49 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=bluez-qt
-pkgver=5.86.0
+pkgver=6.1.0
pkgrel=0
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+arch="all !armhf" # armhf blocked by qt6-qtdeclarative
pkgdesc="Qt wrapper for Bluez 5 DBus API"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
-depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen graphviz qt5-qttools-dev"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/bluez-qt-$pkgver.tar.xz"
+depends_dev="
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ graphviz
+ qt6-qttools-dev
+ samurai
+ "
subpackages="$pkgname-dev $pkgname-doc"
-options="!check" # Multiple tests either hang or fail completely
+_repo_url="https://invent.kde.org/frameworks/bluez-qt.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/bluez-qt-$pkgver.tar.xz"
+# Multiple tests either hang or fail completely
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
cmake --build build
}
+check() {
+ ctest --test-dir build --output-on-failure
+}
+
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-a24f8d6c6bebba3ad71755afe5a311a043a453dad597acff255b73fddee03f8e2835781c5a23de92558803cf0e3751419fca07ea8b6b4f4c4d5c85457b26ec7a bluez-qt-5.86.0.tar.xz
+68bb245313c8394bbca5d5c0e38953f26e2afc094bc82b1c961f726cd00d9b22a3dedb9b980a9e25a128e9d227d84152a8bc8095ff763bff361aae270015b506 bluez-qt-6.1.0.tar.xz
"