aboutsummaryrefslogtreecommitdiffstats
path: root/community/bluez-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/bluez-qt/APKBUILD')
-rw-r--r--community/bluez-qt/APKBUILD41
1 files changed, 30 insertions, 11 deletions
diff --git a/community/bluez-qt/APKBUILD b/community/bluez-qt/APKBUILD
index 9dc1b593ad4..6cf697e2c8a 100644
--- a/community/bluez-qt/APKBUILD
+++ b/community/bluez-qt/APKBUILD
@@ -1,30 +1,49 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=bluez-qt
-pkgver=5.90.0
+pkgver=6.0.0
pkgrel=0
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+arch="all !armhf" # armhf blocked by qt6-qtdeclarative
pkgdesc="Qt wrapper for Bluez 5 DBus API"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
-depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen graphviz qt5-qttools-dev"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/bluez-qt-$pkgver.tar.xz"
+depends_dev="
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ graphviz
+ qt6-qttools-dev
+ samurai
+ "
subpackages="$pkgname-dev $pkgname-doc"
-options="!check" # Multiple tests either hang or fail completely
+_repo_url="https://invent.kde.org/frameworks/bluez-qt.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/bluez-qt-$pkgver.tar.xz"
+# Multiple tests either hang or fail completely
+options="!check"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
cmake --build build
}
+check() {
+ ctest --test-dir build --output-on-failure
+}
+
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-c078d59c200cfefce58c1f5b2b326768e9da35f5f24d67f47cff2d5afe71864c5af64d265ce01f4fc7af963595592f3bbdb6496ada139d3af255c186739f86bd bluez-qt-5.90.0.tar.xz
+58216c448a774dfd8e96b15746a1979f1c70c3d6c7bff1c82ef2486dd98a050d5e72bb46eb0309baf9decc5759e1d6aac7bb68dd650d84803b5f52c6c1e307c2 bluez-qt-6.0.0.tar.xz
"