aboutsummaryrefslogtreecommitdiffstats
path: root/community/bluez-qt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/bluez-qt/APKBUILD')
-rw-r--r--community/bluez-qt/APKBUILD36
1 files changed, 27 insertions, 9 deletions
diff --git a/community/bluez-qt/APKBUILD b/community/bluez-qt/APKBUILD
index 513dfee8385..67244b806a5 100644
--- a/community/bluez-qt/APKBUILD
+++ b/community/bluez-qt/APKBUILD
@@ -1,17 +1,31 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=bluez-qt
-pkgver=5.94.0
+pkgver=6.1.0
pkgrel=0
-arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+arch="all !armhf" # armhf blocked by qt6-qtdeclarative
pkgdesc="Qt wrapper for Bluez 5 DBus API"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
-depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen graphviz qt5-qttools-dev samurai"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/bluez-qt-$pkgver.tar.xz"
+depends_dev="
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ graphviz
+ qt6-qttools-dev
+ samurai
+ "
subpackages="$pkgname-dev $pkgname-doc"
-options="!check" # Multiple tests either hang or fail completely
+_repo_url="https://invent.kde.org/frameworks/bluez-qt.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/bluez-qt-$pkgver.tar.xz"
+# Multiple tests either hang or fail completely
+options="!check"
build() {
cmake -B build -G Ninja \
@@ -22,10 +36,14 @@ build() {
cmake --build build
}
+check() {
+ ctest --test-dir build --output-on-failure
+}
+
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-9599376056de2711faba6e74f6259caa5d641f4c1dadd84967f184736d0437195d0789c322fd81dc3767bafc99232d0899e7728ba90a8c6bac7b8f482fad0ac9 bluez-qt-5.94.0.tar.xz
+68bb245313c8394bbca5d5c0e38953f26e2afc094bc82b1c961f726cd00d9b22a3dedb9b980a9e25a128e9d227d84152a8bc8095ff763bff361aae270015b506 bluez-qt-6.1.0.tar.xz
"