aboutsummaryrefslogtreecommitdiffstats
path: root/community/bmake/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/bmake/APKBUILD')
-rw-r--r--community/bmake/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/community/bmake/APKBUILD b/community/bmake/APKBUILD
new file mode 100644
index 00000000000..d061f85c0c1
--- /dev/null
+++ b/community/bmake/APKBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=bmake
+pkgver=20240404
+pkgrel=0
+pkgdesc="Portable version of the NetBSD make build tool"
+url="https://www.crufty.net/help/sjg/bmake.html"
+arch="all"
+license="BSD-2-Clause"
+subpackages="$pkgname-doc"
+checkdepends="tzdata"
+source="https://www.crufty.net/ftp/pub/sjg/bmake-$pkgver.tar.gz
+ separate-tests.patch
+ "
+builddir="$srcdir/$pkgname"
+
+# Reset MAKEFLAGS since it might contain options not supported
+# by bmake. This is, for instance, the case on the builders.
+export MAKEFLAGS="-j${JOBS:-1}"
+
+prepare() {
+ default_prepare
+
+ # FIXME: Disable tests failing on musl.
+ sed -i unit-tests/Makefile \
+ -e "/deptgt-delete_on_error/d"
+}
+
+build() {
+ sh ./boot-strap --with-default-sys-path=/usr/share/mk op=build
+}
+
+check() {
+ sh ./boot-strap op=test
+}
+
+package() {
+ sh ./boot-strap --prefix=/usr --with-mksrc=/usr/share/mk \
+ --install-destdir="$pkgdir" op=install
+
+ rm -rf "$pkgdir"/usr/share/man/cat1
+ install -Dm644 bmake.1 \
+ "$pkgdir"/usr/share/man/man1/bmake.1
+
+ install -Dm644 README ChangeLog \
+ -t "$pkgdir"/usr/share/doc/$pkgname/
+}
+
+sha512sums="
+91e65c40c07b16762725502de25b03e11bcbc05f2e7b57f861faf9c0f06fcd7e4b9e2de7b8ef56eee870568636c656997f105534ba1e01a3703e703d7fdad1ff bmake-20240404.tar.gz
+320a0175107ed683ef1772a6884be3e0c503ec4d46b0901ae8a9e8cec4c4a5236bec934d9f451142e56addd9e2fe2ea1bc4712b7304570141230e0e1997e7a65 separate-tests.patch
+"