aboutsummaryrefslogtreecommitdiffstats
path: root/community/bolt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/bolt/APKBUILD')
-rw-r--r--community/bolt/APKBUILD35
1 files changed, 26 insertions, 9 deletions
diff --git a/community/bolt/APKBUILD b/community/bolt/APKBUILD
index 746baec1fc3..64d0db26864 100644
--- a/community/bolt/APKBUILD
+++ b/community/bolt/APKBUILD
@@ -1,32 +1,49 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bolt
-pkgver=0.9.1
+pkgver=0.9.7
pkgrel=0
pkgdesc="Thunderbolt 3 device manager"
url="https://gitlab.freedesktop.org/bolt/bolt"
-# s390x and riscv64 blocked by polkit
-arch="all !s390x !riscv64"
+arch="all"
license="LGPL-2.1-or-later"
-makedepends="meson eudev-dev glib-dev polkit-dev asciidoc"
-checkdepends="dbus py3-gobject3 bash"
+makedepends="
+ asciidoc
+ bash
+ eudev-dev
+ glib-dev
+ meson
+ polkit-dev
+ "
+checkdepends="
+ dbus
+ py3-gobject3
+ "
subpackages="$pkgname-doc"
source="https://gitlab.freedesktop.org/bolt/bolt/-/archive/$pkgver/bolt-$pkgver.tar.gz"
+# tests hit a udf instruction, due to some test_notify_teardown pointer free
+# being undefined. using a different allocator fixes it, so musl is being
+# strict about the UB tests here, but the issue is not from the code itself
+options="$options !check"
+
build() {
abuild-meson \
+ -Db_lto=true \
-Dman=true \
-Dsystemd=false \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="c925c290de75d3fa2dfb9e86b2f14ea39279b3f2ab6bebeced72a7853c901d44de02157d684534af2b54edd3a2e0b2ba61e889579ab1b192f99e98a2d73685d9 bolt-0.9.1.tar.gz"
+sha512sums="
+a9ae0425cdba8932356ec4dcf3f6b3469478c01d47ef3b741c0a841117c81b354f35860be6011ea3b43b28ae10164909a82e2bdbcf92e8541c637cf44277a36c bolt-0.9.7.tar.gz
+"