aboutsummaryrefslogtreecommitdiffstats
path: root/community/bolt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/bolt/APKBUILD')
-rw-r--r--community/bolt/APKBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/community/bolt/APKBUILD b/community/bolt/APKBUILD
index 17dc4fed5be..64d0db26864 100644
--- a/community/bolt/APKBUILD
+++ b/community/bolt/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bolt
-pkgver=0.9.2
+pkgver=0.9.7
pkgrel=0
pkgdesc="Thunderbolt 3 device manager"
url="https://gitlab.freedesktop.org/bolt/bolt"
@@ -15,23 +15,29 @@ makedepends="
meson
polkit-dev
"
-checkdepends="
+checkdepends="
dbus
py3-gobject3
"
subpackages="$pkgname-doc"
source="https://gitlab.freedesktop.org/bolt/bolt/-/archive/$pkgver/bolt-$pkgver.tar.gz"
+# tests hit a udf instruction, due to some test_notify_teardown pointer free
+# being undefined. using a different allocator fixes it, so musl is being
+# strict about the UB tests here, but the issue is not from the code itself
+options="$options !check"
+
build() {
abuild-meson \
+ -Db_lto=true \
-Dman=true \
-Dsystemd=false \
. output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
check() {
- meson test --no-rebuild -v -C output
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
@@ -39,5 +45,5 @@ package() {
}
sha512sums="
-69e7ffa58a6dbc8a1b14fd7e11e2291fa60227896ead1a449839716b581c6ab0e351d3ed62f9b51c5e44a5a33ba5e23dc5af73a1b4eef87f733b3231d5454e90 bolt-0.9.2.tar.gz
+a9ae0425cdba8932356ec4dcf3f6b3469478c01d47ef3b741c0a841117c81b354f35860be6011ea3b43b28ae10164909a82e2bdbcf92e8541c637cf44277a36c bolt-0.9.7.tar.gz
"