aboutsummaryrefslogtreecommitdiffstats
path: root/community/boost-build/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/boost-build/APKBUILD')
-rw-r--r--community/boost-build/APKBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/community/boost-build/APKBUILD b/community/boost-build/APKBUILD
index 84805f9f778..a5999d40bba 100644
--- a/community/boost-build/APKBUILD
+++ b/community/boost-build/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer:
pkgname=boost-build
-pkgver=1.78.0
+pkgver=1.82.0
pkgrel=0
pkgdesc="Boost.Build makes it easy to build C++ projects, everywhere"
url="https://boost.org/build"
@@ -15,15 +15,11 @@ builddir="$srcdir/${pkgname#*-}-${pkgname%%-*}-$pkgver"
source="$pkgname-$pkgver.tar.gz::https://github.com/boostorg/${pkgname#*-}/archive/${pkgname%%-*}-$pkgver.tar.gz"
build() {
- # we bootstrapped with boost already
- local _b2="$(command -v b2)"
- local _bjam="$(command -v bjam)"
- cp -p "${_b2:-NOT_INSTALLED}" "$builddir"/src/engine
- cp -p "${_bjam:-NOT_INSTALLED}" "$builddir"/src/engine
+ ./bootstrap.sh
}
package() {
- b2 install --with-python=/usr/bin/python3 --prefix="$pkgdir"/usr
+ ./b2 install --with-python=/usr/bin/python3 --prefix="$pkgdir"/usr
# These binaries are provided by the boost package already
rm -v -rf "${pkgdir:?}"/usr/bin
@@ -34,5 +30,5 @@ package() {
}
sha512sums="
-867966e3d254c0e996786587fb64ad1bda6f96546e5302c15231b17d66537798770bbd9e89f800d445a1f0a4d3be06dff8aed42dfd3a77b563d0f5d715e79324 boost-build-1.78.0.tar.gz
+5f8d46f48e037737e3465e3562c9bdbcacb4a075305c073fe665a8e9c7381ecaa4f5b91a42a9c509cf1c2e0f2af10dbb19f9d443a06fd09edf7372c008d91204 boost-build-1.82.0.tar.gz
"