aboutsummaryrefslogtreecommitdiffstats
path: root/community/borg-space/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/borg-space/APKBUILD')
-rw-r--r--community/borg-space/APKBUILD46
1 files changed, 35 insertions, 11 deletions
diff --git a/community/borg-space/APKBUILD b/community/borg-space/APKBUILD
index ef2b0b086f9..12e264e4555 100644
--- a/community/borg-space/APKBUILD
+++ b/community/borg-space/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: Andy Hawkins <andy@gently.org.uk>
# Maintainer: Andy Hawkins <andy@gently.org.uk>
pkgname=borg-space
-pkgver=0.2
-pkgrel=1
+pkgver=2.2
+pkgrel=2
pkgdesc="Report and track the size of your Borg repositories"
url="https://pypi.org/project/borg-space/"
license="GPL-3.0-or-later"
-arch="noarch !s390x !mips !mips64" # limited by borgbackup
+# riscv64: py3-matplotlib missing
+# armhf: emborg
+arch="noarch !armhf !riscv64"
depends="
- emborg>=1.27
- python3
py3-appdirs
py3-arrow
py3-docopt
@@ -17,19 +17,43 @@ depends="
py3-matplotlib
py3-nestedtext
py3-quantiphy
+ py3-shlib
+ py3-voluptuous
+ "
+makedepends="
+ py3-flit-core
+ py3-gpep517
+ "
+checkdepends="
+ py3-parametrize-from-file
+ py3-pytest
+ py3-pytest-tmp-files
+ py3-pytest-xdist
+ py3-re-assert
+ "
+subpackages="$pkgname-pyc"
+source="https://github.com/KenKundert/borg-space/archive/v$pkgver/borg-space-$pkgver.tar.gz
+ adapt-golden-restults-to-changes-in-voluptous-package.patch
"
-makedepends="py3-setuptools"
-source="https://github.com/KenKundert/borg-space/archive/v$pkgver/borg-space-$pkgver.tar.gz"
-options="!check" # no test suite
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/borg_space-$pkgver*-py3-none-any.whl
}
sha512sums="
-24d7e5fc364cd405af9ee3b6f08d48b4f1badf18508dd56f508c17b1e89a2a06a20455b208dd94e91857e7281d8d00719ae43fedb3cd1bbf302abf603f2f8ff0 borg-space-0.2.tar.gz
+8951474f8f852187b877174d3eafb3cf1754bfc1c843c02f8be1d85b82ab98f4344a98370b26ff36e8a7baa2b5b7999b508e96f988c3b6e14672e84e00e566fb borg-space-2.2.tar.gz
+f01c41c9392d0ca20a9a40a3cf42709f986ae28d8cbe0ff5796fc3fc1b9da7368492d6ec62f72c5a7d0634254aecd7f226641cd5f7e7a9e918b4add82f5452cb adapt-golden-restults-to-changes-in-voluptous-package.patch
"