aboutsummaryrefslogtreecommitdiffstats
path: root/community/borgmatic/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/borgmatic/APKBUILD')
-rw-r--r--community/borgmatic/APKBUILD42
1 files changed, 32 insertions, 10 deletions
diff --git a/community/borgmatic/APKBUILD b/community/borgmatic/APKBUILD
index ddb3a6a87c6..765d4746e4b 100644
--- a/community/borgmatic/APKBUILD
+++ b/community/borgmatic/APKBUILD
@@ -1,42 +1,64 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=borgmatic
-pkgver=1.5.21
+pkgver=1.8.9
pkgrel=0
pkgdesc="Simple, configuration-driven backup software for servers and workstations"
url="https://torsion.org/borgmatic/"
license="GPL-3.0-or-later"
-arch="noarch !ppc64le !s390x" # limited by borgbackup/py3-pyzmq
+# armhf: limited by borgbackup
+# s390x: tests fail
+arch="noarch !armhf !s390x"
depends="
borgbackup
- python3
- py3-setuptools
+ py3-colorama
py3-jsonschema
+ py3-packaging
py3-requests
py3-ruamel.yaml
- py3-colorama
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
"
checkdepends="
py3-pytest
py3-pytest-cov
py3-flexmock
"
+subpackages="$pkgname-bash-completion $pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://projects.torsion.org/borgmatic-collective/borgmatic/archive/$pkgver.tar.gz"
builddir="$srcdir/borgmatic"
+
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+
+ python3 -m venv --clear --without-pip --system-site-packages venv
+ ./venv/bin/python3 -m installer \
+ .dist/borgmatic-$pkgver-py3-none-any.whl
+ ./venv/bin/borgmatic --bash-completion > $pkgname.bash
}
check() {
- # omit a simple test that requires borgmatic to be available in $PATH
- pytest -k "not test_borgmatic_version_matches_news_version"
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ # Requires apprise package that is currently in testing
+ PATH="$PATH:$builddir/.testenv/bin" .testenv/bin/python3 -m pytest \
+ --ignore=tests/unit/hooks/test_apprise.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir" --skip-build
+ python3 -m installer -d "$pkgdir" \
+ .dist/borgmatic-$pkgver-py3-none-any.whl
+
+ install -Dm644 $pkgname.bash \
+ "$pkgdir"/usr/share/bash-completion/completions/$pkgname
}
sha512sums="
-e443c1771d86ae9a33b2eb5f2cdaaad99b8baed618d45e5cf2c4405714e747613c17d59ab0eeebb76b1ad96e606f3ff4dd24415dd15383fe0c6ca296db34c199 borgmatic-1.5.21.tar.gz
+65109fb5ece95022cfce44c58bb38ffa63e64913f61ede13d611382b8039ecf37f07fcdb687b1d3ac7e83dba11ed0ccda4a50ff88c48c8100de50125d891a31c borgmatic-1.8.9.tar.gz
"